Go Down

Topic: Relay ground loop "hum" - not present when using mechanical switch (Read 796 times) previous topic - next topic

Dane

Hi!

I'm trying to switch one of the three internal wires which run to a phone in my house.
When I do this with a mechanical switch and simply introduce a break in the wire, attach one side to one pin of the switch and the other side of the break to the other pin, things work as unexpected.

If I use an Arduino controlled relay, I get the most awful deep hum on the line (ground loop?).

I had understood that the switched connectors on a relay were independent from the rest of the circuit, being controlled by an electromagnet which I had supposed didn't actually touch.

Does anyone know how I might be able to be rid the hum, or if it's for some reason part and parcel?

Thanks

Nick Gammon

http://www.gammon.com.au/electronics

jacksonguitardog

It would be much better to have a schematic or full description of your application. Unwanted hum and other noise can be introduced into the circuit in many ways. In a high gain audio application, the circuit may suffer from SCIN (shield current induced noise), noise caused by different potentials of ground at two locations, ground loops, high gain with unbalanced or unshielded circuits, power supply noise, and just plain poor grounding.

Elaborate on your setup, and we may be able to help.

Dane

How the relay circuit is wired:

How the relay interfaces with the Arduino and the phone cable.


I'm just surprised because I had understood that the switched pole was isolated electrically from the relay/arduino/PSU.

Grumpy_Mike

Quote
I had understood that the switched pole was isolated electrically from the relay/arduino/PSU.

It is.

But the long lengths of wires act as an antenna and pick up electromagnetic interference from close by mains wiring.
You can try wiring it up using screened cable. Note only ground one end of the screen on a cable not both to prevent ground loops. 

Go Up