Go Down

Topic: Arduino Mega + Ethernet Shield con IDE 1.0 [SOLUCIONADO] (Read 1 time) previous topic - next topic

amino

Apr 24, 2012, 12:32 pm Last Edit: Apr 25, 2012, 09:53 pm by amino Reason: 1
Hola a todos.

Soy nuevo en esto y estoy bastante perdido. Agradezco cualquier ayuda. Este es mi problema:
Necesito conectar la Ethernet Shield al Arduino Mega. He encontrado esto por la web: http://mcukits.com/2009/04/06/arduino-ethernet-shield-mega-hack/ pero en el IDE 1.0 no aparece el fichero spi.h en el directorio: hardware/libraries/Ethernet/utility (que es lo que dice que hay que cambiar en software para que funcione). He descargado el IDE 0015 que es del que hablan en el tutorial y en ese sí que está el fichero, pero no se me abre el IDE...

Muchas gracias.

chiva

Si la has comprado hace poco (menos de un par de años) no hay que hacer nada para que funcione
Si pones una foto de la placa ethernet, mejor
Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

amino

Creo que es más antigua (me la han prestado y no estoy seguro).
Aquí está la foto:

JRodrigo

Creo que la placa que tienes esta http://shieldlist.org/arduino/ethernet, en ese mismo link tienes el pinout del shield.

En el IDE 1.0 la librería ethernet es compatible con las placas MEGA por lo tanto no tendrás que modificar nada, solo tienes que "puentear" los pines que te dice en el link que has puesto.

Quote
MEGA pin 50 (MISO) to Arduino Ethernet Shield pin 12.
MEGA pin 51 (MOSI) to Arduino Ethernet Shield pin 11.
MEGA pin 52 (SCK) to Arduino Ethernet Shield pin 13.
MEGA pin 53 (SS) to Arduino Ethernet Shield pin 10.


Un saludo!


amino

Muchas gracias por responder.
Ya lo había probado (y lo he vuelto a hacer), pero no me funciona. Estoy programándolo con el ejemplo WebServer que viene en el IDE, pero nada. Sin embargo con la placa Arduino Uno sí me funciona.
Seguiré probando.
Muchas gracias.

Go Up