Pages: [1]   Go Down
Author Topic: Please help me troubleshoot my boarduino  (Read 616 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 72
Carpe Diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi All,

I've been trying to set up a boarduino. I have chip with the blink program set to pin 1. My problem is however that my board wont work.. I've assembled and reassembled it twice, but the led wont start blinking. When I measure the voltage into the chip, it's at about 4.97 volts. Voltage prior to the regulator is 12 volts. When I put the chip back into the regular arduino board, the led blinks correctly.

I've posted pictures, perhaps you guys can follow it? (i mean the wiring?) Ive gone over it at least 15 times, and couldnt see what's causing it.

PS, my caps are off spec.. is that whats causing the problem? One is 22uf 100v, and the other is 100uf 16v.  smiley-grin

I dont have any other caps to use, and i accidentally fried one of my chips, so im feeling kinda bad about that.. :l

please see the images.



http://img716.imageshack.us/img716/2161/25334148.jpg
http://img822.imageshack.us/img822/8057/83631499.jpg
http://img843.imageshack.us/img843/5918/78391837.jpg
http://img256.imageshack.us/img256/9871/85178481.jpg
http://img718.imageshack.us/img718/8673/39718144.jpg
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 631
Posts: 34493
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Pin 1 is used for serial communications and should not be used unless you know what you are doing, the same goes for pin 0.

You have no series resistor in line with your LED, that can damage your arduino.

You have no decoupling capacitors on the processors supply input.
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 495
Posts: 19035
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Are those caps replacing the 0.1 uF decoupling caps?

How are you programming it? What error message, if any, are you getting?
Logged


Global Moderator
Offline Offline
Brattain Member
*****
Karma: 495
Posts: 19035
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Is that a pull-down resistor on reset? Shouldn't it be pull-up?
Logged


Offline Offline
Jr. Member
**
Karma: 0
Posts: 72
Carpe Diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Nick,

thanks for your reply! im using the blink example, but just replaced pin 13 with pin 1. there are no errors, because i pop the chip back into the arduino when I program, then pop it back into the breadboard after its done.

I'm not sure what the difference is between pull up and pull down.. but I'm following this schematic attached. Also, regarding the caps, it says 22
 on it. But I previously had NPO22J on them but those didnt work either.. Am I using the wrong parts? smiley



* hackduino.pdf (219.41 KB - downloaded 7 times.)
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 86
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A pull up pulls the pin UP to Vcc, a pull down pulls it DOWN to GND. You need the resistor to your reset pin to be a pull UP. Crystal caps need to be 22pf (although I've used 27pf successfully).

I think the decoupling caps for the power supply need to be 10uf, but I don't think matching that is as important as having the correct caps on the crystal.

Definitely make the resistor on pin 1 a pull up, the way you have it right now your chip is not going to be able to start up.
« Last Edit: April 26, 2012, 10:56:47 am by boredat20 » Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 72
Carpe Diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset



just real quick about the basics of a cap.. the value of uf is just the capacity of electrons it can store yes? And the voltage printed on it just shows how much voltage it's rated for yea? Would it make sense to combine 2 5uf in parallel to get the same results as just 1 uf?

ps the reset pin will be activated when it gets voltage? or is it the other way around where it resets when it when it loses the voltage?

thanks again for your help smiley
Logged

0
Offline Offline
Shannon Member
****
Karma: 214
Posts: 12406
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Your decoupling capacitors need to be right next to the chip - best to place a 100nF (ie 0.1uF) or similar directly between pins 6 and 7, and another one between pins 20 and 22 (that's pin numbers of the chip, not the Arduino numbering).  A 10uF or similar can be anyway on the board so long as it is present.

The values of decoupling capacitors are not critical - the proximity of the high-speed decoupling capacitors to the chip is the most important point.

You don't need a pull-up on the RESET line, there's one internally.  However if you want reliable operation in high-noise environments (big motor controllers etc) it would be wise to add a 4k7 pull-up to the reset line.
Logged

[ I won't respond to messages, use the forum please ]

Offline Offline
Jr. Member
**
Karma: 0
Posts: 72
Carpe Diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just got home and rearranged the resistor.. It seems to be working fine now! smiley Thanks everyone!
Logged

Pages: [1]   Go Up
Jump to: