Pages: [1] 2   Go Down
Author Topic: probleme module Bluetooth  (Read 2661 times)
0 Members and 1 Guest are viewing this topic.
Chulak
Offline Offline
Full Member
***
Karma: 2
Posts: 234
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour je viens de recevoir mon module bluetooth, mais j'arrive pas a le démarrer ...

après étude visuelle de module j'ai l'impression qu'un composant est mort ..

ci-joint le module avec le composant que j'ai l'impression d'être hs .. mais par contre je vois pas ce que c'est,

condensateur, ou resistance..


* img_2619.jpg (301.55 KB, 1698x737 - viewed 44 times.)
Logged

Aimez la Vie, mais preferez la Mort, car seulement celle-ci vous liberera des tenebres de la Vie.

Ile-de-France (92 sud), France
Offline Offline
Edison Member
*
Karma: 24
Posts: 2055
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Je dirai un condensateur mais je vois pas trop pourquoi il serait mort.
Il me semble correct.

Peut être pourrais tu être plus précis sur ce que tu as tenté pour le faire marcher ?
Connexion, code, etc ...
Logged

Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Chulak
Offline Offline
Full Member
***
Karma: 2
Posts: 234
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

l'image que j'ai mis est une image pris sur le web de mon module, donc normale que le composant a l'air correct..

J'ai tenter d'alimenter le module seul, sans connecter rx et tx sur l'arduino, j'ai lu les infos dessus, sa dis qu'une led doit clignoter si il n'y a pas de synchro et qu'elle reste allumer avec la synchro.

dans mon la led ne s'allume jamais .. :s ...

j'ai quand même tenter de lancer une recherche avec mon téléphone, je n'ai pas trouver le nom fourni par la doc ..

ensuite niveau code j'ai juste tenter une p'tit code avec du serial. mais sans succée.

par contre je vois pas si il faut d'abord via code arduino activer le module .. ou simplement l’alimenter suffit ..
Logged

Aimez la Vie, mais preferez la Mort, car seulement celle-ci vous liberera des tenebres de la Vie.

Ile-de-France (92 sud), France
Offline Offline
Edison Member
*
Karma: 24
Posts: 2055
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Le module devrait démarrer dans le mode de configuration auquel il répond aux commandes AT.

Si tu as un module/câble USB/TTL genre celui-ci tu peux relier son TX au RX du module et vice-versa pour communiquer avec lui par un programme de terminal (tel que TeraTermPro ou le SerialTerminal de l'IDE Arduino).
Les paramètres par défaut sont 9600 Baud, 8 bit, no parity.

En lui envoyant AT<cr>   (les lettres A puis T puis la touche entrée) il devrait répondre OK

N'oublie pas que c'est un module 3V3, pas 5V !


J'ai commandé le mien aux US chez MDFLY. Pas cher mais La Poste US à perdu le paquet. J'enrage.
J'en ai commandé un autre en Chine chez LedSee mais 3 semaines et toujours rien reçu.....
Logged

Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Chulak
Offline Offline
Full Member
***
Karma: 2
Posts: 234
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

pour le module usb ttl .. j'en ai commander 1.. mais pas encore recu..

enfaite ce que je trouve bizarre, c'est que j'ai commander 2 module bt.. et les deux me dise rien.. lol..
Logged

Aimez la Vie, mais preferez la Mort, car seulement celle-ci vous liberera des tenebres de la Vie.

Ile-de-France (92 sud), France
Offline Offline
Edison Member
*
Karma: 24
Posts: 2055
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Soit t'as vraiment pas de bol avec une série foireuse.
Soit tu rates quelque chose dans le câblage.

Comment branches tu la chose ?
Logged

Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Chulak
Offline Offline
Full Member
***
Karma: 2
Posts: 234
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ben sur la uno, vcc = 3.3, gnd = gnd lol.. rx bt = tx uno, tx bt = rx uno

Logged

Aimez la Vie, mais preferez la Mort, car seulement celle-ci vous liberera des tenebres de la Vie.

83 - var
Offline Offline
God Member
*****
Karma: 9
Posts: 864
ARDUINO Powa !
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

euh la tu ne doit pas croiser rx et tx pour ton module bluetooth sa c'est en filaire entre deux machine.. enfin il me semble..
skizo !
Logged

Un tien vaux mieux que deux tu l'auras !

Ile-de-France (92 sud), France
Offline Offline
Edison Member
*
Karma: 24
Posts: 2055
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Câblage pour que l'arduino discute avec le module.
Le câblage que tu obtiens est donc celui ci :



Comme tu le vois, avec cette config, l'Arduino peut envoyer un message au module BT avec un Serial.write() par exemple.
Tu peux aussi voir ce message dans le SerialTerminal de l'IDE Arduino.
Mais si le module répond, seul l'Arduino voit la réponse.

Pour commencer, je te propose de travailler uniquement avec le PC <--> Bluetooth

Charge dans l'Arduino un programme qui ne fait rien :
Code:
void setup() { }
void loop() { }

et câble comme cela :



Comme cela le PC parle au BT et reçoit le BT
Utilise le SerialMonitor, réglé sur 9600 et "Carriage return" au lieu de "no line ending".
En haut tape  AT   puis <Send>

Le module BT devrait te répondre OK.
Logged

Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Chulak
Offline Offline
Full Member
***
Karma: 2
Posts: 234
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Barbudor, d'abord merci de ton aide..

mais malheureusement sa ne fais rien du tout .. j'ai tester les deux modules, sur ma uno et ma mega, je n'ai aussi réponse.
Logged

Aimez la Vie, mais preferez la Mort, car seulement celle-ci vous liberera des tenebres de la Vie.

Ile-de-France (92 sud), France
Offline Offline
Edison Member
*
Karma: 24
Posts: 2055
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

J'avoue n'avoir plus aucune idée.
j'attends toujours le mien ...
Logged

Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Offline Offline
Jr. Member
**
Karma: 1
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonsoir à tous,
Sur mon projet j'utilise un module bluetooth également (en 9600 bauds) et lors d'un mauvaise manip je l'ai mis à mal.
J'en ai commandé un autre totalement identique et la, impossible de m'y connecter.
En fait celui-ci fonctionnait à 115200 bauds.
Une fois reparamétré à la bonne vitesse, tout à bien fonctionné de nouveau.
Cordialement
JP
Logged

Chulak
Offline Offline
Full Member
***
Karma: 2
Posts: 234
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

salut bricopin,
sniff, ton info m'avais redonner un peux espoir.. mais sa n'a pas marché.. ^^..

j'ai tester sur toute les bauds disponible.. dans arduino ..
Logged

Aimez la Vie, mais preferez la Mort, car seulement celle-ci vous liberera des tenebres de la Vie.

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Juste une petite info qui pourrai débloquer la situation.
J'avais par le passé galéré pendant une bonne semaine avec un écran lcd série, impossible de communiquer avec lui, le silence total.

J'avais fait des recherches et découvert qu'au niveau de Rx et Tx se trouve deux résistances qui ont pour but de rendre prioritaire la communication usb série -> atmega.
Pour plus d'info : http://www.billporter.info/how-to-add-multiple-uart-connections/

Étant donnée que ton module bluetooth travail en 3v3 celui ci doit (c'est même sur) comporter des résistances pour réduire le 5v en 3v3.
Ces résistances en parallèle de celle intégré à l'arduino doivent créer un pont diviseur, et affaiblir les signaux série à un tel point que l'arduino ne "vois" plus rien.

Tente de communiquer avec ton module bluetooth au travers d'une liaison série software (avec newsoftserial par exemple) il y a de forte chance que tout fonctionne comme par magie car il n'y aura pas de résistances smiley-wink
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
Jr. Member
**
Karma: 1
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour à tous,
As tu également tester les différentes valeur de bits de stop et de parité.
Pour ma part il a fallut que je les modifie également.
Cordialement
JPR
Logged

Pages: [1] 2   Go Up
Jump to: