Pages: [1]   Go Down
Author Topic: Trouble with the parallel programmer  (Read 603 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello

It's my first time trying to use an ATMega168 with no pre-burned bootloader.
I read some stuff online and made my own parallel programmer.

I connected it to my Duemilanove using the 6 ICSP pins, but I can't program anything with it.

Tried Arduino software, avrdude, pony prog... all of them are telling me that they cannot find the device.
The yellow led (L) on my board is on while the cable is plugged and flashes only once when I click "burn bootloader" in arduino, after that i'm getting an error.


the error message is

"avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: Yikes! Invalid device signature.
avrdude: Expected signature for ATMEGA168 is 1E 94 06"

I also checked the options that I am using "Parallel Programmer" and "Arduino Diecimila or Duemilanove w/ ATmega168" board in the Tools menu.


Can anyone help me?
I need it kinda urgent



forgot to mention... my board is connected at a 12V power supply while trying to burn the bootloader


thanks
« Last Edit: April 27, 2012, 10:41:17 am by Trika » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

no ideas?

it's urgent
Logged

Gosport, UK
Offline Offline
Faraday Member
**
Karma: 21
Posts: 3113
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I would double check that your programmer is built correctly. Perhaps post images so that the experts here can look it over. Avrdude is reading the wrong ID from your 168. You need to determine why.

Please realise that what is urgent to you, isn't to anyone else. People will help when they can, but have their own lives to be getting on with.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yes...sorry for that

i re-made the programmer again this morning. tried to shorten the cables, but no changes. same problem.

avrdude isn't reading the wrong code. I think it's not reading anything at all.

here are some images of the parallel programmer

http://imageshack.us/g/403/img004yx.jpg/
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

tried it on a breadboard...
same thing.

LED flashes once and same error message

avrdude says "device not responding initialization failed, rc=-1"

if I use -F, to override the check, it find "device signature = 0x000000"
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

nothing? anyone?
Logged

Pages: [1]   Go Up
Jump to: