Go Down

Topic: seed bluetooth shield > tinkerProxy > flash (win7) (Read 2206 times) previous topic - next topic


hey guys -
i'm trying all day getting seed bluetooth shield running with tinkerProxy an Flash on windows 7.
i already got it running on osx. i have no problems get it running via USB …
it seems i gone throgh all tutorials, trough all google hints.

how ever. i can start two sscom32 session and send data via seed bluetooth shield to arduino an back like described in this tutorial http://www.seeedstudio.com/wiki/index.php?title=Bluetooth_Shield

but if i try to run / connect (via flash or also telnet) COM5 (bluetooth shield) with tinkerProxy 2.0 / SerProxy 0.2.0 i just geht the "failed to open comm port - connection refused" message. (ich i do the same with arduino via usb - all fine) - the bluetooth shield really seems to do something, because the seed bluetooth shield stops blinking red/green and i thinks it got a connection somehow…

Code: [Select]




do you have any idea - can you help me out?
thx for your replies - tobi


thanks to http://lj9.mexinetica.com/bloginetica/comentarios.shtml?2011. i got a little bit further … i get a connection and Serproxy throws "thread started" … but flash doesn't seem to get any data.

if you have something on this. please let me know.
otherwise i'll keep you updated if i manage to get it running.

kind regards,


Hi Tobi,

Did you ever figure this out? I'm stuck at the same exact point. I got a usb bluetooth dongle. When I use Putty, I am able to see the arduino data just fine via bluetooth (the usb dongle directs this data to the serial connection on com4 on my windows 7 laptop). But I cannot read this into Flash. I tried both Tinkerproxy 2.0, and the update in your link which says fixes this issue with bluetooth. Doesn't seem to work. I can connect in Flash, but then no data. The onArduinoData handler only triggers once (and rarely at that). From Putty, I do need to send the bluetooth dongle the commands "at", and then "
atdmle,ecfe7e101354" which is to connect to my bluetooth device on the arduino. After that, the data comes through fine on Putty. So I thought I need to use the Ardunio send command from Flash to send these initial commands. Tried that but also doesn't work. Any ideas much appreciated.




sent you a private message to get together to fix this problem (again ;)
=> we'll post the solution later in here, i promise. no. Andre promises.

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131