Pages: [1]   Go Down
Author Topic: [HELP] Suddenly Arduino Mega ADK Lost serial connection in Win7 32bit  (Read 1276 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi all.

I am using arduino mega ADK right now, having project with my android.
The trouble is suddenly my mega ADK lost connection from windows when running sketch.

The situtation is like this:
1. My mega ADK is running well before, i can upload blink sketch, try my LCD 16x2, etc
2. Today i have to finish my project with android, and i make revision on my android and arduino.
3. ok, everything is set and ready for test, i am using external power supply (12v ; 2,5A) plug to DC power jack in arduino mega ADK, plug the usb type a into ADK board and plug the type B usb.
4. i plug the power supply into the power outlet and the usb to my laptop (win7 32bit) and i plug the android usb into the android device (T-Mobile G1).
5. The all are working nicely, and i want to test it, i shake my android and move around, and in serial monitor the data all i need is out.
6. Maybe about 30minutes, suddenly i lost my arduino ADK on my laptop, serial monitor closed, nothing happen, nothing message appear in my windows.
7. i unplug the usb on my laptop and android devices, now i plug the usb to laptop (still using external power supply), and nothing happen, my windows did not detect my arduino ADK, device manager did not detect any COM port or DFU mode, tried on my PC with winXP, same happen, no COM port, no DFU detected.
8. I try without any power supply, just USB, in my laptop and PC, and same condition, windows did not detect any COM port in device manager.
8. The power LED is still on, and i notice nothing is burned.

This is what i've done till now.
1. I check my ATmega2560 using external programmer, and its works, blink and fade works fine, even the usb host woks too.
2. I notice that near ATmega8U2 Chip, exist another ICSP, i've tried to upload MEGA-dfu_and_usbserial_combined.hex, and its done, but the result is zero, my laptop and PC did not detect any DFU or COM Port.

Any suggestion how to solve this?

Thanks You all smiley
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the same problem. The serial connection had been working, but it went away last week. I have tried 6 different computers, running Windows 7, Windows XP, Mac OS, and Ubuntu Linux. I have had some intermitent success with using the serial monitor, but it is usually not there. On the Tools menu, Serial Port is grayed out. I have been mostly using a Mega 2560. My troubles started after I tried uploading a program to a Duemillenove. I can't upload any program to either Arduino. Is the bootloader damaged? If so, how do I restore it?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had also something smilar with an Arduino UNO and Win7.
The USB is connecting and the arduino is found by the system but when I try to upload the sketch I always get the errormessage "avrdude: stk500_getsync(): not in sync: resp=0x00"
When connected, only the "ON" LED is on and the L LED doesn't blink. I used the the PIN 0 and 1 to read a switch and used a extrenal 12V power supply while uploading.

I think one of these things had damaged my arduino, maybe u did somethng similar?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My problem turned out to be the USB cable going bad.
Logged

Pages: [1]   Go Up
Jump to: