Pages: 1 [2]   Go Down
Author Topic: LEDs und Transistoren  (Read 2666 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 0
Posts: 238
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

okay und nun meine (hoffentlich) abschließende Frage kann ich bei meinen Vorhandenen 12V LEDs diesen einfach einen zusätzlich oder neuen Widerstand verpassen und dann arbeiten die mit 5V auch am Arduino?
Logged

Offline Offline
Edison Member
*
Karma: 21
Posts: 1419
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@sth77: *rofl* hatte die Antwort parallel geschrieben nur noch nicht abgeschickt. Komme vom Kaffee-holen wieder, schicke den Post ab und lese meinen Artikel fast 1:1 nochmal. Wenigstens hab ich mich nicht verrechnet :-)
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 238
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@all und cool finde ich es dennoch wie sich hier um die "Elektroniknieten" gekümmert wird. So macht das Lernen echt Spaß. Keine dummen Sprüche, nein, nett und freundlich wird einem hier alles erklärt, wenn man (=ich) es nicht rafft.
vielen lieben Dank an euch alle
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 238
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Doofe Frage, aber ich möchte es jetzt einfach Wissen bevor ich etwas zerstörre. Wenn ich das ganze für 9Volt Leds mache, kann ich dann einfach den 9Volt Ausgang vom Arduino nutzen oder muss ich ausser dem Umrechnen des Transistorwiderstandes noch etwas beachten?
mfg
Balli
Logged

Germany
Offline Offline
Edison Member
*
Karma: 48
Posts: 2338
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Die 9V kannst du vom VIN-Pin direkt entnehmen. Die Formulierung Transistorwiderstand verstehe ich jedoch nicht. Meinst du den Basiswiderstand? Der ändert sich doch nicht.
Logged

Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

Offline Offline
Full Member
***
Karma: 0
Posts: 238
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

muss ich denn jetzt nicht  R = U / I -> R = 9 V / 0.005A = 1800 Ohm rechnen?
mfg
Balli
p.s. ich werde mich bemühen Basiswiderstand zu schreiben
Logged

Offline Offline
Edison Member
*
Karma: 21
Posts: 1419
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nein, nicht für den Basiswiderstand des Transistors, der hängt doch weiter am 5V Pin des Arduino. Lediglich die 9V für die LEDs kommen aus dem Vin. Dabei jedoch aufpassen, solltest Du mal ein anderes Netzteil verwenden, liegt natürlich dessen Ausgangsspannung an Vin an. (z.B. 12V bei einem 12V Netzteil).
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 238
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Okay, danke das leuchtet ein.vielen Dank.
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 238
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Forum,
ich habe meine LEDs mit Transistoren nun wie beschrieben gebastelt /zusammengestellt. Leider funktioniert das ganze nicht so wie es soll (jetzt kommt der Punkt mit der Glaskugel).
Punkt 1: Ich habe meine 4 LED-Stränge zusammengelötet (also nur die LEDs und deren Widerstände und dann eben die Verkabelung)
Punkt 2: Ich habe meine Transistoren, deren Widerstände auf ein Steckbrett gesteckt
Punkt 3: 3 von 4 Strängen funktionieren
Punkt 4: bei Strang 4 ist am Steckbrett die Plaste geschmolzen und der Transistor sieht nicht mehr original aus
Punkt 5: Strang 4 an einen anderen Transistor geschaltet passiert nichts (also auch kein Licht an)

Nun meine  Fragen, warum hat der Spaß angefangen so extrem heiß zu werden(1.) (die anderen Transitoren waren nicht erwärmt) und woran kann es liegen das Strang 4 kein Licht angegangen ist-fehlerhaftes Zusammenlöten schließe ich mal aus (einfach weil das ein Fehler ist, den ich mehrfach überprüft habe und nochmals werde)(2.).
Und drittens was kann ich alternativ an Stelle des Steckbrettes nehmen, etwas was die Temperaturen abkann oder noch besser gibt es für solche Transistorenschaltungen eventuell auch Shields?(ich habe nach so etwas schon gegoogelt, aber ich verwende wahrscheinlich die falschen Suchbegriffe)

mfg
Balli

Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21871
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Damit der Transistor heiß wird und kaputgeht und das Steckbrett schmilzt mußt Du einen Fehler in der Verdratung oder in der Auswahl der Bauteile gemacht haben. Strang 4 ist ja gleich dem Strang 3 wenn ich das richtig vom ersten Post verstanden habe. Mehr kann ich nicht erraten. Kristallkugel ist in Reinigung  smiley-wink smiley-wink smiley-wink

Zu den 9V vom Arduino an pin Vin ist zu sagen, daß die Spannung von dem Netzteil abhängt das Du verwendest. Arduino hat eine Schutzdiode gegen Verpolen drin und die hält 1A aus.

Wenn Du eine LED mit 5V Vorwiderstand an einer anderen höheren Spannung betreiben willst dann brauchst Du einen weiteren Vorwiderstand. Der errechent sich aud der Spannungsdiffeenz gebrochen durch den LEDstrom. Wahrscheinlich ist der LEDstrom 20mA ist aber leicht zu messen. Einfach Ampermeter in Reihe zur 5V-LED schalten und an 5V anschließen.

Grüße Uwe 

Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 238
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich habe extra 9 V LEDs gekauft, damit ich diese am 9V Anschluss betreiben kann. Angenommen meine LEDs sind alles richtig gepolt, wo könnte dann der Fehler bei der Verdrahtung liegen?
Kann es sein, dass meine Kabel zu lang sind?So in etwa 6Meter (also 3 Meter hin und 3 Meter zurück*G*)
mfg
Balli
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21871
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Der Transistor geht kaput wenn keine Last  sprich LED angeschlossen ist, sondern er direkt an + und Masse angeschlossen ist. Die Länge der Kabel ist egal. Kontrolliere mal ob nicht ein Kurzschluß zwischen den beiden Kabeln der LED ist.

Wenn die LED verpolt ist fließt kein Strom.
Grüße Uwe
Logged

Pages: 1 [2]   Go Up
Jump to: