Poll
Question: usb port problems
howe to solve - 0 (0%)
how it hapens - 3 (100%)
Total Voters: 3

Pages: [1]   Go Down
Author Topic: avrdude: stk500_getsync(): not in sync: resp=0x30  (Read 3461 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
I don't is topic about egsist or not but I run with error "avrdude: stk500_getsync(): not in sync: resp=0x30". And about it can't find good info how to solve it. So I making a topic about it.
I solve this error finaly (I hope) reinstaling arduino and its driver. I using windows 7 64bits.
If some knows the better way for this error please write. Becose I believe he comes back. And changing ports not solution.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hapen again. What i should do please help. Can't use my arduino.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I´ve gotten the same problem, i got my arduino uno, a week ago, so here my experience so far:

1)  I never got the green led to turn on when connect arduino to my macbook pro.
2) tx led nor rx led blink, when trying to upload a sketch
3) after trying to upload any sketch, i get this message: avrdude: stk500_getsync(): not in sync: resp=0x00

I dunno if im doing anything wrong, so far ive follow step by step number of posts in forums and websites, but still not working


* IMG00399-20120504-1939.jpg (398.09 KB, 1600x1200 - viewed 30 times.)

* IMG00400-20120504-1947.jpg (405.19 KB, 1600x1200 - viewed 23 times.)
Logged

if its not broken, dont fix it, instead open it and look how it works

Holland
Offline Offline
Jr. Member
**
Karma: 0
Posts: 93
Troubles are there to be solved!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

is the atmega chip insert correctly? (does the mark on the chip match the mark on the DIP-packet)

is this a problem wich happens all the time or is it just randomly and works just fine..?
just asking so people have a better view on the problem..
Logged

humankind cannot obtain anything without
sacrificing something of equal value.

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

this happens everytime i try to upload a sketch, also tried to keep the reset button pressed before, during, after upload the sketch
Logged

if its not broken, dont fix it, instead open it and look how it works

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

well, here´s some update of the issue:

I tried to load sketches on windows XP, it didnt work...
I also tried using a different USB cable, I think the usb cables i have are working fine, so the problem must be somewhere else


the chip is correctly inserted
the problem happens everytime I connect arduino to my macbook pro, I ve been able to load a sketch properly in very few times


any help?

Logged

if its not broken, dont fix it, instead open it and look how it works

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

can´t even upload the blink sketch, really frustratting!!!!!!!!!
Logged

if its not broken, dont fix it, instead open it and look how it works

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I managed to upload a modified blink sketch:

void setup() {               
  // initialize the digital pin as an output.
  // Pin 13 has an LED connected on most Arduino boards:
  pinMode(13, OUTPUT);     
}

void loop() {
  digitalWrite(13, HIGH);   // set the LED on
  delay(1000);              // wait for a second
  digitalWrite(13, LOW);    // set the LED off
  delay(500);              // wait for a second
}



so the time the led is off its half of the on time (nothing impressive); the first time i did it, it worked fine, so I tried to again, but this time it didnt work and instead I got that annoying message:
"avrdude: stk500_recv(): programmer is not responding"

Is there any cause im not considering in the process?

IS this  normal in Arduino? i mean this unstability, sometimes works, some other times doesnt....


Logged

if its not broken, dont fix it, instead open it and look how it works

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

looks like the way to "solve" it is to press the reset button at the precise moment (which is frustrating task to do) in order to load a sketch....
anyone has found a different (actually working) solution?
Logged

if its not broken, dont fix it, instead open it and look how it works

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This solution worked for my UNO on Windows 7 64-bit.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This solution worked for my UNO on Windows 7 64-bit.

Thanks! Ill try tonight at home, and keep posted!
Logged

if its not broken, dont fix it, instead open it and look how it works

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i tried to do something similar to this last indication, but honestly it was imposible to follow the instructions since they are meant for win7.... not mac which is my case

so again: any ideas about how to solve this in mac?
Logged

if its not broken, dont fix it, instead open it and look how it works

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I got this message the first time I tried to use my uno it turned out that I was using the wrong com port I changed the com port and it worked. I don't know if this will work for someone else I just know that is what was wrong with mine when I got that same error message
avrdude: stk500_getsync(): not in sync: resp=0x30 I realize that this is an old post and these problems have probably been solved but this might help someone else like me who came here and there was no solution there is one now thank you Tom.
Logged

Pages: [1]   Go Up
Jump to: