Pages: [1]   Go Down
Author Topic: FIXED: File Association Problem When Upgrading Arduino to 1.0 on Windows  (Read 842 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 64
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Passing this along in case others have had this issue when upgrading Arduino on Windows platforms:

I've been upgrading my machines from Arduino-0022 to Arduino 1.0.  After upgrading, I had issues with the .ino file association in Windows, both XP and Win7 64bit.  After installing 1.0 I changed the file association to point to Arduino.exe in the Arduino-1.0 folder.  My preferred method for browsing and opening Arduino files is through Win Explorer, opening via double clock on the source file.  But after upgrade and updating the .ino file association to point to the Arduino 1.0 .exe, double clicking from Win Explorer continued to open the Arduino-0022 IDE.

Some searching led me to this -> http://answers.microsoft.com/en-us/windows/forum/windows_7-files/problems-with-file-association-in-windows-7-64-bit/8a84fcec-22df-4942-8e35-d98dbe96e327  It appears Arduino does not register itself properly when upgraded, after an initial key is established in the Win registry.

After saving a restore point, I used Regedit to navigate to My Computer\HKEY_CLASSES_ROOT\Applications, and finding Arduino.exe I navigated to shell>open>command.  In the Default I changed its location to point to the correct location of the 1.0 Arduino.exe executable (it was still pointing to the old -0022 Arduino.exe location), hit okay and then reassociated the ,ino file type as normal.  It worked.

The linked post above is for Win7 but this fix worked for my Win7 and WinXP machines.
« Last Edit: May 05, 2012, 02:34:36 pm by MGeo » Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 64
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Also, another fix I came across.  To fix multiple instances of COM port numbers for a single Arduino board on Win7:

http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/6c4a6394-0b01-4ccb-af9b-da172f554796

1. Modify environment variable to permanently the normally hidden display ‘Phantom‘ devices in Device Manager.  Under Start, right-click Computer > Properties > Advanced System Settings > Advanced Tab > Environment Variables at the bottom. Click New and put devmgr_show_nonpresent_devices in the Variable Name and put 1 in the Variable Value and OK your way out.

2. Under Start, right click Computer > Properties > Device Manager.  Toggle Show Hidden Devices on under view menu.  You should now see the hidden installed devices all listed even if they are not plugged in.

Process is similar under XP, set environment variable to 1 and make sure view is toggled on in Device Manager.  http://support.microsoft.com/kb/315539

George

If your computer doesn't recognize your Arduino and won't install the proper drivers, this fix may work. It has been used for Arduino UNO with Windows 7 64-bit, so steps may vary for other devices and operating systems.

1) Go to the "Unknown device" which is the Arduino.
2) Click around in the "Hardware" tab to open a window with the "Update Driver" button on it. Click it.
3) Choose the option to find the driver from a list on your computer. Then choose "Let me pick from a list of device drivers on my computer".
4) Scroll down and choose "Ports".
5) Choose "Arduino LLC" and then "Arduino UNO". If there is no "Arduino LLC" option, follow the steps below:
  a) Click the "Have Disk" button.
  b) Point to the Arduino folder, then to the "drivers" folder, then select the .inf file for your particular device (In my case it was Arduino UNO.inf).
6) Install the driver. Ignore any warning messages about verification of publication.
7) The Arduino should now be listed as a COM port instead of an unknown device. In the IDE click Tools > Serial Port and select the new COM port.

Full credit for the solution to this problem:

Tutorial with pictures
Tip for those without the LLC option
« Last Edit: May 08, 2012, 03:55:50 am by MGeo » Logged

Pages: [1]   Go Up
Jump to: