Go Down

Topic: Windows 7 Unknown Device FIXED (Read 27 times) previous topic - next topic


May 06, 2012, 07:59 pm Last Edit: Feb 24, 2014, 09:39 pm by Coding Badly Reason: 1
If your computer doesn't recognize your Arduino and won't install the proper drivers, this fix may work. I used it for my Arduino UNO with Windows 7 64-bit, so steps may vary for other devices and operating systems. I'm writing this from memory so sorry if there are some gaps.

1) Go to the "Unknown device" which is the Arduino.
2) Click around in the "Hardware" tab to open a window with the "Update Driver" button on it. Click it.
3) Choose the option to find the driver from a list on your computer. Then choose "Let me pick from a list of device drivers on my computer".
4) Scroll down and choose "Ports".
5) Choose "Arduino LLC" and then "Arduino UNO". If there is no "Arduino LLC" option, follow the steps below:
  a) Click the "Have Disk" button.
  b) Point to the Arduino folder, then to the "drivers" folder, then select the .inf file for your particular device (In my case it was Arduino UNO.inf).
6) Install the driver. Ignore any warning messages about verification of publication.
7) The Arduino should now be listed as a COM port instead of an unknown device. In the IDE click Tools > Serial Port and select the new COM port. In my case it was COM5.


I give these people full credit for the solution to this problem:

Tip for those without the LLC option



Thank you. This worked like a charm.
University of Regina
Software Engineering Major
Electronic Engineering Minor


I tried this and many other win 7 fixes, i have win 7 x64 and nothing worked. It showed up as a unknown device and when i try to point to the driver it starts to install but says a driver could not be found. I did about a hundered things and then i did this:

My solution was to move the driver for arduino uno rev 3 to the C:\Windows\inf\  folder. Then uninstall the unknown device unplug it plug it back in adn it took like 5 seconds to intall i was so happy. I only post this because it wasnt on most of the threads like this one it didnt work for me.


Go Up