Go Down

Topic: [HOWTO] Guida (più o meno) completa all'utilizzo di Moduli Bluetooth (Read 82 times) previous topic - next topic

Testato


Quote
- e' da chiarire quando dici che la velocita' standard degli HC05 e' 38400, in realta' la velocita' di comunicazione settata di fabbrica e' uguale per tutti i moduli e cioe' 9600, e' la velocita' da usare per la programmazione AT che e' 38400. Per spiegarmi meglio, se tu prendessi un modulo HC05 e lo lasciassi cosi' come da fabbrica, per collegarti dovresti usare 9600.


uhm questa è da approfondire. La velocità di default è quasi per tutti 9600 - quella dell' HC05, avendoci fatto parecchie modifiche, non me la ricordavo e avevo ritrovato il datasheet del venditore, in cui era segnato appunto 38400.

In realtà, cambiando baudrate, se reimpostavo la seriale a cui era connesso il modulo (es. con adattatore usb2serial), mettendo la nuova velocità la comunicazione avveniva senza problemi. Viceversa no.
Quindi quel che ne deduco è che esiste una sola velocità, che vale sia per la seriale via bt che quella "fisica".


Ho fatto dei test sulla velocita' delle due seriali.
Sul mio HC-07 si comporta cosi':
- settata con comandi AT seriale modulo a 19200
- lancio due terminali uno sulla Com seriale HW del modulo, e l'altro sulla seriale BT del modulo.
- Se cambio le impostazioni del terminal usato sulla com hw, settandolo ad esempio 11500, non mi funziona piu' la connessione.
- Se cambio le impostazioni del terminal usato sulla com bt, funziona.

Lato seriale BT si puo' usare indifferentemente qualsiasi velocita'. E' forse un comportamento comune per tutti gli aggeggi con profilo SPP ?

- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

yassino

ciao a tutti, ho creato l'app consigliatami da pitusso seguendo una guida, lo scaricata nel cellulare, ho caricato lo sketch sull'arduino.
riesco a connettere il cellulare al modulo bluetooth pero' quando premo su led on non si accende il led 13.
non riesco a capire quale' il problrma, mi aiutate a capire cosa devo fare?!? appena comprato bisogna impostare via codice il modulo bluetooth? in modalita' master o slave forse?


con blueterm riesco solo a vedere cio' che viene scritto sul serial monitor non riesco a controllare niente.
ciao

pitusso

Ciao
il tuo modulo dovrebbe già essere impostato a slave, altrimenti non lo vedresti neppure.

La connessione è corretta, secondo quanto riportato nella guida (magari posta pure una foto)?


yassino

per connessione corretta intendi il circuito o la connesione via bluetooth??

Go Up