Pages: [1] 2   Go Down
Author Topic: Help - StandaloneAVR Atmega168.  (Read 1178 times)
0 Members and 1 Guest are viewing this topic.
India
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am facing a "Nothing Happening" kind of problem and that is...
 smiley

I am trying to put the Atmega168 over Breadboard. It is Pre-installed with Arduino Boot loader.

Trying to plant the BAREBONE circuit over breadboard but its not happening.
Means the chip is not getting boot-up. That is PIN 19(SCK) is not emmiting Volts over my LED which i have connected.

overall, the chip is not Getting start, i think!

Enclosure:
a snap of my Breadboard Setup.
A circuitry diagram which i am following while putting components on to breadboard.



please correct me where i am going wrong or so.
Diagrams which i am following is from Internet.


Thanx!  smiley-confuse


* IMG005.jpg (412.31 KB, 2048x1536 - viewed 16 times.)

* IMG006.jpg (420.13 KB, 2048x1536 - viewed 15 times.)
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
That is PIN 19(SCK) is not emmiting Volts over my LED which i have connected.

Pin 19 is not supposed to emit volts. It is an incoming SCK not an outgoing one.
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok,

but still....... my AVR setup is not working.

is my sketch is correct?!!!

how could i detect over breadboard that wether the bootloader is Detected or not!!

I gues thats y, the SCK pin is indicated with a LED .

 smiley-small
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What sketch?
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

"SKETCH"  smiley-sweat means ,


i mean that the DIAGRAM which i have pasted along with my POST!



y my MCU is not working with me!!!!! smiley-sad

everything is set:= Depends on external Clock:TRUE!   so i have placed an external clock too!
whaat else required..

even now i have grounded the RX pin with 10k res too! to not communicate serially!!

what next and how!! smiley-sad
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
"SKETCH"  ... means ,

http://arduino.cc/en/Guide/Environment

Quote
Software written using Arduino are called sketches. These sketches are written in the text editor. Sketches are saved with the file extension .ino.

(My emphasis)


Quote
i mean that the DIAGRAM which i have pasted along with my POST!

So you don't need to shout at me.

Quote
y my MCU is not working with me!!!!! smiley-sad

everything is set:= Depends on external Clock:TRUE!   so i have placed an external clock too!
whaat else required..

even now i have grounded the RX pin with 10k res too! to not communicate serially!!

Don't understand that, sorry.
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

 smiley-cry
 smiley-sweat


Yes sir.


ok, now, my MCU is still not working on breadboard!

smiley-sad


I followed ur Arduino-Compatible Post, and i found that i have done the simillar way of circuit, but still my MCU is not working.


Is my MCU is angry with me or what!!! smiley-sad
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I can't see much from that photo. And the diagram doesn't show what is happening to SCK.

And what have you connected to it?

You have to give more information.
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Tell you what...

You show me a photo like this:



That shows what is connected to what. Then we can talk.
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

 smiley

Yes sir, thats the same...

but the scenario is...

i have burnt the <i>Sketch</i> into chip by placing into Arduino board, then i detach the MCU and placed it onto breadboard.
now i want my MCU to do according to the program which is already there in.

after fitting all over breadboard according to requirements, my MCU is not showing any activity or so.

now i want my MCU to go alone on its own but its not happening and i am powering my breadboard externally with help of 7805 IC n a battery!
Logged

Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 439
Posts: 23797
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So, assuming you have the LED wired in series with a resistor to +Gnd (neither the picture nor the schematic show what is connected),
and the Reset pin properly pulled up to +5V:

Post you sketch so we can see what you are trying to do.
[ code ]
your code goes here
[ / code ]
Leave out the spaces between the brackets, and it ends up like this when you click on Post:
Code:
your code goes here
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

India
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yes sir....



my LED is from SCK(19) to resistor , lastly GND.

my code which i have burnt is....


Code:
void setup(){
pinMode(4, OUTPUT);
}

void loop(){
digitalWrite(4, HIGH);
delay(500);
digitalWrite(LOW);
}


Just a basic One sir....

The thing is my MCU is not starting UP!!!
and hence my LED over pin 6 i.e pin4 on Arduinois not Glowing up.


One more thing is: while the Bootloader is been detected or found! the SCK....19th pin blinks up fastly na?!!!!
That also not happening!!!!!


Rest, the current condition is same as before....!!! not working!!!
and the other side of this is when i place my CHIP back to ARDUINO BOARD, its works fine! smiley-cry
Logged

Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 439
Posts: 23797
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Well, this is not correct:

pinMode(4, OUTPUT);

you need to use 13 for the SCK pin with the normal Arduino software setup.

Also, this

digitalWrite(4, HIGH);
delay(500);
digitalWrite(LOW);

will appear to the naked eye to immediately write HIGH after the delay is done - add a delay(500); after the write Low, or you will never see the low.

Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes sir, thats the same...

but the scenario is...

... i am powering my breadboard externally with help of 7805 IC n a battery! ...

... and hence my LED over pin 6 i.e pin4 on Arduinois not Glowing up.

Well it's not the same is it? I don't want you to assure me that you have the "same" setup as me, and in the next breath talk about a voltage regulator and an LED.

Take a photo. A clear photo. Post it.
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Again, i tried this morning and my MCU is not loving me !!!!!!means not working!!

enclosing pics of the arrangement and tried to keep it clean with labeling too!!!

the code which i have burnt is:


Code:
void setup(){
pinMode(4, OUTPUT);
}

void loop(){
digitalWrite(4, HIGH);
delay(500);
digitalWrite(4, LOW);
}



thanx for ur replies.......


* IMG010.jpg (1582.19 KB, 2048x1536 - viewed 22 times.)
Logged

Pages: [1] 2   Go Up
Jump to: