Pages: 1 [2]   Go Down
Author Topic: Help! Unable to upload codes!  (Read 1764 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 62
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I should add that when I press the reset button, pin 13 does not light.  Does this mean my Arduino is toasted somehow, or do I need to burn another bootloader?  This board is less than 2 months old.
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17301
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I has the same problem when i replace the ATMega 328 with one ATMega 328 speedy 2x from ADAFRUIT
I solve the problem when i choose other board
I choose LilyPad Arduino w/ATMega 328 and work fine now
I dont know why happen this I am newby in electroniks
Try somethink this Maybe help you


One thing you are selecting when you select a board type is the baudrate to use to upload a sketch. If you change the 328 chip in a Uno board with one that has an older bootloader then you must NOT select it as a Uno board as the baudrates won't be correct.

Lefty

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Ipsolutions,

I´m new to the Arduino family, but I think you should try the code with a new Atmega chip on your  board. Perhaps your Atmega chip is broken. Good luck.......
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17301
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Ipsolutions,

I´m new to the Arduino family, but I think you should try the code with a new Atmega chip on your  board. Perhaps your Atmega chip is broken. Good luck.......

No, before you spend any money (and waste time) on a part that may not be the problem, you should perform the serial loop back test to see if the board's 8u2 USB serial convertor chip is functioning or not. A failure of serial communications for any reason will give you the error code you are seeing.

Steps:

1. unplug board from pc.
2. Put a jumper wire from a ground pin to the reset pin.
3. Put a jumper wire from digital pin 0 to digital pin 1.
4. Open the arduino IDE and click on tools/serial port and write down the avalible ports.
5. Close the arduino IDE
6. Plug in the arduino to the PC, it should sound the new USB connection, if not you have a PC arduino driver problem.
7. Open the arduino IDE and click on tools/serial port and you should see a new port number that wasn't shown in step 4. If you don't have a new port number avalible you have a PC arduino driver problem.
8. Select the 'new' comm port number.
9. Click on the serial monitor button.
10. Anything you type in the serial monitor's send window and then send should echo back into the monitor's receive window.

 If that works then you have no serial communications problems, only then might you want to try a new replacement 328 chip. Be sure you know what bootloader is installed in the replacement chip you purchase as that determines what board selection you have to use.

If the serial test does not work then there is mostly likely a problem on your arduino board other then the 328 chip and you will not cure it by replacing the 328 chip.

Lefty
« Last Edit: June 27, 2011, 07:42:52 pm by retrolefty » Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 62
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did as you suggested, and device does echo monitor input.  So apparently is a microprocessor problem, and I will need to replace the 328 chip? 
Thanks for the suggestions, at any rate.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello everyone, I'm new here and maybe the solution I've found had been posted earlier, but I couldn`t find it, so that's the story.

I was testing an serial programmer I've made for the 50$robot in the Arduino Uno cause I had problems programming it and didn´t kew if the programmer or the board were bad wired. I attached the programmer (the one I've done is based in this one http://www.societyofrobots.com/robotforum/index.php?topic=7626.0 to the ISP of the arduino and uploaded some .hex on it using ponyprog, clicking "ignore". Since the program was well uploaded and everything seemed to go right, I continued with the other board and left the Arduino for later.

Several days later I tried to upload some code on the Arduino uno using the USB inteface and the IDE and got the same error, the receiving led blinked three times but the sending one were always off. In somewhere between my confusion and my frustration I've recalled that I had programmed the board using the serial programmer and realized that probably it overwrote the bootloader.
In this page http://arduino.cc/en/Hacking/Bootloader explains where to find the correct .hex for my board, in the \hardware\arduino\boards.txt, and uploaded it. That solved the problem.
Seems that the big problem came cause ponyprog overwrites the entire flash, avrdude has an option to solve this, but I could't yet configure it to use the serial programmer I've made, but this is another story, and another hardware.
« Last Edit: July 01, 2011, 07:32:30 am by Kondemor » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi All, just solve it by changing the port from COM3 to COM4 ....
Logged

Pages: 1 [2]   Go Up
Jump to: