Go Down

Topic: [Résolu] Problème driver sous Windows 7 (Read 12845 times) previous topic - next topic

Snowgoons

May 09, 2012, 09:01 pm Last Edit: May 10, 2012, 02:29 pm by Snowgoons Reason: 1
Salut à tous !

J'ai un soucis avec windows 7 : je trouve pas comment installer les drivers de l'Arduino (Uno) pour pouvoir balancer un programme dessus.

Et je n'ai pas accès dans le menu Tools à la section Serial Port pour sélectionner le COM1 !

Si quelqu'un peut m'aider...

Quand je veux installer les drivers dans le gestionnaire de périphérique windows ne les voit pas

Merci !

barbudor

1) Pour installer un driver il faut généralement avoir les droits administrateur (ce qui est le cas si tu es l'utilisateur principal sur un Windows Home, ce qui n'est probablement le cas si tu es un utilisateur en entreprise)

2) Quand tu branches ta UNO, que se passe t'il ? Windows est sensé soit installer tout seul le driver soit te dire qu'il n'en a pas trouvé et te propose le choix de lui indiquer l'emplacement sur le PC où trouver le driver (genre "Me laisser choisir un driver")
Dans ce cas il faut lui indiquer d'aller chercher le driver dans le sous répertoire drivers de là où tu as installé ton environnement Arduino.

3) Sinon fait clic bouton droit sur l'icone "Ordinateur" du bureau et choisir "Gérer"
Approuver le passage en mode
Dans la colonne de gauche trouver Gestionnaire de périphérique.
Dans l'arbre qui apparait à droite tu devrait avoir un périphérique avec une icone en forme de triangle jaune.
Cliquer avec le bouton droit -> mettre à jour le pilote
Choisir "Rechercher un pilote sur mon ordinateur"
Indiquer le répertoire ci-dessus et Suivant
Continuer jusqu'a la fin et ca devrait être bon
Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Snowgoons

#2
May 09, 2012, 09:13 pm Last Edit: May 09, 2012, 09:18 pm by Snowgoons Reason: 1
Merci pour ta réponse rapide.

1) Oui j'ai les droits administrateurs

2) Quand je branche ma Uno il me dit effectivement qu'il n'a pas trouvé de driver mais il me propose juste d'aller en chercher sur internet et évidemment il ne trouve rien...

3) J'ai déjà fait cette manip, je met bien le chemin du dossier FTDI USB Drivers et il ne trouve pas les drivers non plus

Voilà ce que j'ai pour la partie 3) :


barbudor

je n'ai pas écrit "FTDI USB Drivers"
J'ai écrit "drivers", le niveau d'en dessous,  là où il y a "Arduino UNO REV3.inf" qui est le seul fichier dont tu as besoin pour une UNO
Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Snowgoons

Ah d'accord merci ça marche, bizarre parce que le site d'arduino j'avais trouvé un tuto qui disait de mettre le dossier que j'avais mis moi

barbudor

Pas pour une UNO.
Uniquement pour les modèles qui utilisent le chip FTDI pour l'interface USB/série genre Duemilanove etc ...
A+
Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

flyhigh91

Bonjour a tous,

puisque le post etait deja là, j'ai cru bon de ne pas ouvrir un autre post pour le meme sujet. XD

Voilà!!! j'ai le meme probleme que bien du monde concernant l'installation du fameux driver sur le systeme d'exploitation windows 7.
j'ai durement travailler et lu sur tout le forum imaginable pour essayer de resoudre ce probleme... en vain..... =(

j'ai essayé la metode qui permet, a l'aide du gestionaire de preripherique, de proceder a une installation manuel de l'appareillage.(comme mentionné plus haut).

cependant, vue l'echec de mes multiples tentative, j'ai fouillé d'avantage sur internet pour ensuite tenter une autre methode.

la voila:

  1  Copie manuelle du fichier Arduino UNO.inf dans windows/inf
   2 Copie manuelle du fichier usbser.sys dans windows/system32/drivers
   3 connexion de l'ARDUINO UNO sur usb
   4 ouverture de la fenêtre "Gestionnaire de périphériques"
   5 clic droit sur le port com et clic sur "Désinstaller"
   6 déconnexion de la carte ARDUINO UNO
   7 reconnexion

Et là, c'est suporé fonctionner a merveille ...Mais bien sur pas pour moi ....

alors je chercher desperement de l'AIDE venant d'un sympatique expert en la matiere


Cobrasse

Bonsoir,

Merci d'avance pour toute l'aide que vous pourrez m'apporter.

J'ai acheté récemment un Arduino UNO et visiblement ce coquin veut me faire brûler des neurones !!!

Je suis sous windows 7 32bits, j'ai les droits d'administrateur et j'ai suivi l'installation décrite sur le site d'Arduino :

http://arduino.cc/en/Guide/Windows#toc4

Seulement à la connexion du UNO, je reste en périphérique inconnu sous les gestionnaire au niveau de la partie : ports (COM & LPT). Impossible d'avoir : "Arduino UNO (COMxx)".

Il m'indique dans les propriétés de ce périphérique inconnu :

- Fabricant : Arduino LLC

mais l'état du périphérique :

Quote
Ce périphérique n'est pas configuré correctement. (Code 1)

Une section d'installation de service dans ce fichier INF n'est pas valide.


Pour trouver un pilote pour ce périphérique, cliquez sur Mettre à jour le pilote.
J'ai beau mettre à jour le pilote, copier le fichier arduino.inf dans le fichier inf de windows ... Rien n'y fait.

le pilote semble installé, mais pas exploitable ... Serait-ce du à un service windows particulier qui ne serait peut être pas activé ? J'ai pourtant d'autres périphériques en USB qui ne pose pas de soucis : manette Xbox360, DSPiy, clé USB ...

Sur un autre PC celui du bas, j'ai le droit au code 28 :o .

Cette technique ne fonctionne pas non plus, une fenêtre me dit qu'il a bien trouvé le pilote pour mon périphérique, mais qu'il a rencontré une erreur en tentant de l'installer è_é !

....

Bon je vais pas supprimer mon post, mais en réalité il me manquait pour une raison que j'ignore le fichier usbser.sys qui est appelé dans le driver arduino.inf .

J'ai téléchargé et copié ce dernier dans C:\Windows\System32\drivers . Je refais la MAJ du pilote et boom, détecté !

OUF

Bon bah merci à vous ^^

Didou61

Bonjour.

nouveau dans le monde arduino, je peine dés le départ.

Je n'arrive pas à installer mon arduino uno. "echec de demande de description de périphérique".

A la lecture des forums, j'ai bien compris qu'il s'agit d'un problème de driver. Cependant je bloque toujours au même endroit : lorsque je tente une mise à jour du pilote, après avoir renseigné le répertoire, j'obtiens la réponse "le meilleur pilote est déjà installé" et donc pas de mise à jour.
J'ai essayé cette manip sur 4 pc, toujours le même problème.

Comment faire ?

Didou

fdufnews

#10
Dec 24, 2015, 04:55 pm Last Edit: Dec 24, 2015, 04:56 pm by fdufnews
En ne donnant pas plus d'information sur ta carte on ne peut pas trop t'aider.
Sur les versions chinoises il y a maintenant un ch340 comme interface USB, il nécessite un driver qui n'est pas livré avec l'IDE arduino ton problème vient peut-être de là.
Vérifie sur le composant, si c'est le cas voir ici : https://forum.arduino.cc/index.php?topic=237772.msg1709742#msg1709742

Didou61

Bonjour.
Merci pour l'aide.
Il s'agit d'une copie achetée chez mini**thebox.
Il y a une puce carrée, 32 pattes identifiée Mega328P    AU1530.
Face à tous ces problèmes, je me suis acheté une genuino chez arduino, et là bingo cela marche du premier coup.
Maintenant si je pouvais trouver une solution pour celle-ci, cela m'éviterais de la mettre à la poubelle  :smiley-confuse:
Didou

fdufnews

#12
Dec 24, 2015, 09:49 pm Last Edit: Dec 24, 2015, 10:02 pm by fdufnews
il doit y avoir une autre puce qui assure l'interface USB

Le lien que j'avais donné semble mort. Voir là:
http://www.wch.cn/product/CH340.html

Didou61

Bonjour.

A l'aide d'une bonne lampe de poche et d'une loupe, j'ai pu identifier une écriture  ch340 sur une puce.
Je vais donc chercher dans cette direction.
Merci pour cette info judicieuse. :)

Didou


Shiyo

Bonjour,
J'ai un problème similaire une carte chinoise que j'ai achetée (étant étudiante je n'ai pas beaucoup de moyen). J'ai acheté ce kit: http://fr.aliexpress.com/item/UNO-R3-KIT-Upgraded-version-of-the-For-Starter-Kit-the-RFID-learn-Suite-Stepper-Motor/32248407835.html
J'ai codé et branché mon premier exercice du TP mais lorsque je branche l'Arduino, mon PC sous windows 7 n'arrive pas à mettre le pilote, sous Linux il ne me le trouve même pas. J'ai vue sur internet la technique qui consiste à aller dans le gestionnaire de périphériques et de faire chercher le driver par le PC dans le dossier drivers du programme Arduino mais il ne trouve rien (décidément aussi doué que moi l'ordinateur ^^). Si je tente de téléverser le programme, Arduino me met cette erreur:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x9d
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x9d

J'ai essayer de désinstaller puis réinstaller le programme Arduino, d'appuyer sur le bouton reset pendant le téléversement... rien à faire!
La carte est détectée par le gestionnaire de périphérique mais n'arrive pas à installer le driver pour la faire fonctionner.
Quelqu'un pourrais me venir en aide? Je suis nouvelle en Arduino

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy