Go Down

Topic: Attiny85 programming failing - Invalid device signature (Read 11 times) previous topic - next topic

Ishkur

I'm trying to program an Attiny85 using an Arduino Uno, but no luck...

With 1.0, following http://hlt.media.mit.edu/?p=1695:
Used arduino isp sketch from here: https://github.com/arduino/Arduino/blob/master/build/shared/examples/ArduinoISP/ArduinoISP.ino
Attiny definitions from here: https://github.com/damellis/attiny/zipball/Arduino1
Tried fixing baud rate from 19200 to 9600 as described here: https://github.com/arduino/Arduino/commit/80a2154279a02fd69f995ef6ff9eb889363c73ca

Sketch uploads ok unto the Uno, but when I try burning the tiny's bootloader (8Mhz internal osc)...

I get this
"avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check."

First one is dismissable, second one no... I read somewhere that it might be the UNo's reset that isn't being correctly prevented, and the programmer is trying to burn the bootloader unto the 328, hence the signature problem, but I tried with and without a 10uF capacitor between RESET and GND (and even a 100uF), but nothing...


Tried doing the programming with 0.22 (http://hlt.media.mit.edu/?p=1229) instead of 1.0 (both the arduino isp uploading and attiny bootloader burning) with provided attiny defs.
Same error message...


Weird thing is some months ago I tested programming the same chip and managed to get it to work by uploading the Arduino ISP sketch with 0.22, and then burning the bootloader. Going back to 1.0 worked fine.
Now I get the same error message on either version (0.22 or 1.0).
Checked and double checked all the connections, changed jumper cables, nothing...

johnwasser

If you turn on verbose output you will get to see the value of the received signature.  If it matches the ATmega328P then you are accidentally resetting the UNO.  If it is all 0's or all FF's you have an incorrect connection on the target processor.
Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Ishkur

I'm getting either "Device signature = 0x000000" or "Device signature = 0xffffff". Alternates when I re-connect the reset jumper on the tiny...
Changed all jumper cables again, but nothing changes...

Fried tiny? (hopefully no, as it's really hard to find them here in Portugal)

johnwasser

Sounds like one or more of the six connections to the ATtiny are misplaced or broken.

D10 -> Pin 1  (Reset)
Gnd -> Pin 4
D11 -> Pin 5  (MOSI)
D12 -> Pin 6  (MISO)
D13 -> Pin 7  (SCK)
+5V -> Pin 8
Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Ishkur

That is (unfortunately) exactly how I have it connected...
Since I changed  all the jumper wires twice, and tested all the wires before the last switch, I'm kinda stumped on this one...

Arduino pins are all ok (tested input and output with blink and pushbutton sketches for each one), so my only guess is the tiny isn't working...  =(

Go Up