Pages: [1]   Go Down
Author Topic: RF link 2400 bps Empfänger 434 empfängt nicht richtig  (Read 1137 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Full Member
***
Karma: 3
Posts: 151
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,
habe mir auf Empfehlung einen RF link Empfänger für 434 MHz (Watterott) zugelegt.
Damit will ich die Daten von Funk-Wetter-Sender decodieren. Die Dinger sind
bei Aldi Funkwetterstationen übrig geblieben (Typ WT440 von Dario). Ich hab
schon alle mögliche Software ausprobiert, nichts funktioniert.
Angeschlossen habe ich den  Digital Output an digital Pin 2 vom Arduino
UNO. Die Hardware muss jedoch i.o. sein, da ich mit dem Programm
ShowReceivedCode die Daten von einer Funk-Fernbedienung YCT-100 problemlos
empfange und decodiere. Hatte mir die Sache einfacher vorgestellt. Wer kann
helfen und hat Hinweise oder Software, die funktioniert ?

Gruss Kalli
 P.S.

Auch ein Sender der Firma TFA (aus dem Bauhaus) funktioniert nicht. Habe ich den falschen Empfänger ?
« Last Edit: May 12, 2012, 10:19:59 am by Kalli » Logged

Offline Offline
Sr. Member
****
Karma: 1
Posts: 260
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

ich hab auch einen Sender von TFA, der funkt aber mit 868 MHz.

Laut dem Datasheet sendet der Dario-Sender mit 433 MHz, das sollte theoretisch also hinhauen.
http://www.dmv-electronics.com/download/BDA_Wetterstation_DMV-JHB1_DE.pdf
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 30
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Kalli

Habs selber noch nicht gemacht, aber habe auch in näherer Zukunft vor, unsere Wetterstation anzuzapfen.

Bin bei meiner Suche immer mal wieder on OOK vorbeigekommen. Also eine Art Amplitudenmodulation. Solche Nachrichten empfängt das Demo-programm nicht, ist aber wohl gängig in der Wettersensoren-Ecke.

http://jeelabs.net/projects/cafe/wiki/Receiving_OOKASK_with_a_modified_RFM12B

Vermutlich hilft dir das bei deinen Versuchen weiter.

Viele Grüße, Holger

Logged

0
Offline Offline
Full Member
***
Karma: 3
Posts: 151
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,
erstmal recht herzlichen Dank für die Antworten.
Der Sender von TFA sendete auf 434 MHz. Leider funktioniert das alles nicht. Habe auch nichtmal im Ansatz
eine Lösung gefunden. Von den RFM Modulen hatte man mir abgeraten, da die FM statt AM machen. Auch sind die RFM Module
nicht so einfach in der Anwendung. Mir wurden diese einfachen Module empfohlen, für die ich leider keine Anwendung finden kann. Scheinbar habe ich hier Neuland betreten. Werde das erstmal zu den Akten legen.

Danke

Gruss Kalli
Logged

Hamburg, Germany
Offline Offline
Full Member
***
Karma: 2
Posts: 191
Hello world!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Der Sender sendet ja nur in bestimmten Intervallen, lange genug gewartet? Wie sieht Dein Sketch aus?
Logged


0
Offline Offline
Full Member
***
Karma: 3
Posts: 151
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo sui,

ja, ich habe lange genug gewartet, zumal ja eine grüne LED leuchtet, wenn sie senden. Ich habe einige Programme ausprobiert,
mit Exemple ShowReceivedCode konnte ich zwar die Daten einer Fernbedienung auslesen, jedoch keine Meldung
irgend einer Art von dem Wetter-Sendern.
Deine Nachfrage beunruhigt mich, habe ich mein Problem wirklich so schlecht beschrieben ?

Gruss Kalli

P.S. auch Exemple ThermoHygroReceiver gibt keine Meldung ab...
Logged

Pages: [1]   Go Up
Jump to: