Pages: 1 [2]   Go Down
Author Topic: Problema arduino collegamento usb  (Read 2322 times)
0 Members and 1 Guest are viewing this topic.
Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 327
Posts: 22651
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Anche io ho avuto dei problemi simili su seven e ubuntu 11.04 non mi riconosceva la uno ma mi riconosceva la 2009 ho dovuto reistallare i driver della MB e questa accadeva su qualunque porta mi collegassi.Ancora adesso ho dei problemi certe periferiche (htc android viene visto come USB1.0 ed inoltre ho aggionata tutti i driver che ho trovato.
Linux non ha bisogno di driver aggiuntivi per rilevare la UNO, sono già integrati nel kernel. Caso mai va assegnato l'utente ai giusti gruppi per poter accedere alle periferiche seriali virtuali.
Logged


Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 327
Posts: 22651
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

led accesi sono "ON" e pin 13 (quello integrato)
Il led 13 non deve stare acceso di suo ma solo se lo comandi dallo sketch. Se resta acceso e sei sicuro di non avere un programma che lo usa forse hai danneggiato la scheda con un collegamento sbagliato?
Un'altra prova da fare è quella di verificare se su un altro computer o sistema operativo viene visto oppure no. Se sì allora è un problema del tuo computer, altrimenti può darsi che sia proprio la schedina partita.
« Last Edit: May 12, 2012, 02:19:22 pm by leo72 » Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ho comprato una scheda nuova..già che cero anche il microprocessore tanto costava 4 euro quando arriverà proverò a cambiare il processore magari e solo quello che e andato vi farò sapere grazie a tutti smiley
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

il 13 mi si accende sempre quando non lo uso, con tutti i programmi che gli avevo caricato... giustamente al "blink" lampeggiava, se a un programma gli davo al 13 Low non si accendeva...

comunque avevo già provato su un'altro pc win7 con stesso risultato, volevo provare su ubuntu ma non so come muovermi per gestire l'arduino...  smiley-confuse
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 327
Posts: 22651
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Devi solo installare qualche pacchetto ed assegnare l'utente ad un gruppo
http://arduino.cc/playground/Linux/Ubuntu
Logged


Cagliari, Italy
Offline Offline
Tesla Member
***
Karma: 112
Posts: 7079
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ciao a tutti, sono nuovo del forum  smiley-lol

anche io ho lo stesso problema da qualche giorno:

ho un arduino uno rev3 che non viene neanche rilevato come un dispositivo sconosciuto, si prende solo l'alimentazione.
se provo a fare upload di un'altro programma, giustamente, mi dice che la porta com3 non c'è e di andare a selezionare la porta giusta... peccato che non mi fa selezionare nessuna porta  smiley-sad , avevo già caricato un'altro programma che continua a funzionare, se vado alla "gestione dispositivi" non c'è (comprese porte com).
ieri ho reinstallato windows (non per questo motivo  smiley-sweat ) e ho cercato di installare il driver di arduino, ma anche ora se vado alla "gestione dispositivi" non viene rilevato come "dispositivo sconosciuto con driver non installato ecc..." quindi... come glielo installo il driver??  smiley-confuse il mio arduino è "defunto"??  smiley-roll-blue

ho cercato in giro, ma non ho trovato niente... qualcuno mi può aiutare??

Con la Arduino R3 è cambiato il chip di controllo della USB. Necessità quindi del suo driver specifico.
Lo trovi nelle cartelle di Arduino. Il Driver è "ArduinoUno.inf", non il FTDI USB Drivers che è per le vecchie versioni.
Logged

Code fast. Code easy. Codebender --> http://codebender.cc/?referrer=PaoloP

Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Con la Arduino R3 è cambiato il chip di controllo della USB. Necessità quindi del suo driver specifico.
Lo trovi nelle cartelle di Arduino. Il Driver è "ArduinoUno.inf", non il FTDI USB Drivers che è per le vecchie versioni.

so come si installa il driver (tanto è vero che prima facevo tutti gli upload che volevo), il problema è che l'arduino non viene proprio rilevato dal pc ma prende solo la sua alimentazione di 5v dall'usb...

qualcuno ha idee su come risolvere il problema?
Logged

Taranto, Puglia
Offline Offline
God Member
*****
Karma: 1
Posts: 758
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

ciao inanzitutto grazie smiley niente il problema e che il vecchio programma che ho caricato funziona ancora e credo stia bloccando la seriale perche il computer non vede che è attacccato non dice niente ma semplicemente prende i suoi ricchi 5v :s

innanzitutto scusami tu se non ho risposto ma ho avuto molto da fare smiley-sweat
A me invece capita (2 volte su 3) che quando carico il programma nuovo, se è collegato qualche sensore o anche solo un semplice led, non me lo fa caricare. invece poi stacco tutto, ricollego arduino e tutto ritorna a funzionare
PS: ho arduino rev2 quindi con chip 8u2
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

sono andato dal rivenditore e nonostante gli abbia cambiato chip non funzionava, quindi me lo rimanda indietro e se Dio vuole lo riavrò fra 3 o 4 settimane.. ne dovrò fare a meno per un pò  smiley-cry

vi ringrazio per l'aiuto che mi avete dato  smiley
Logged

Pages: 1 [2]   Go Up
Jump to: