Pages: [1]   Go Down
Author Topic: No life after Uno R3  (Read 819 times)
0 Members and 1 Guest are viewing this topic.
Centurion RSA
Offline Offline
Full Member
***
Karma: 0
Posts: 166
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi guys,
After I connected my first Uno R3 to my laptop, none of the older boards or programmers work.

I reloaded the Duemilanove with the standard and the optiboot boatloader but the IDE does not see any of them. It does not see the Uno R3 or the Arduino Mega either.
My IDE does not see the AvrIsp mk2 or the Pololu programmer (AvrIsp v2)

Is there maybe an issue with a windows driver or am I missing something stupid here?

 smiley-sad
Logged

Rather people think you to be a fool than you open your mouth and confirm it.

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 485
Posts: 18807
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ah, Windows. smiley

Did you install the new USB driver that came with the Version 1.0 of the IDE? It is different for the Rev 3 board.
Logged


Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Do any of these devices show up in Device Manager when connected to the system?
Logged

Centurion RSA
Offline Offline
Full Member
***
Karma: 0
Posts: 166
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ah, Windows. smiley

Did you install the new USB driver that came with the Version 1.0 of the IDE? It is different for the Rev 3 board.

Nick,
As far as I know, yes I did. I have had the Arduino 1.0 running for some time already.
The sad thing is that the older stuff is not working anymore.
Logged

Rather people think you to be a fool than you open your mouth and confirm it.

Centurion RSA
Offline Offline
Full Member
***
Karma: 0
Posts: 166
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Do any of these devices show up in Device Manager when connected to the system?

Louis
They all show in the device manager. The IDE does not talk to them. I get a stk500 timeout. or sync problem.
Logged

Rather people think you to be a fool than you open your mouth and confirm it.

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Since they all show in Device Manager, then we can focus on something with the IDE.

When you say the IDE does not "see" them, do you mean none of the COMM ports show up under Tools -> Serial Port menu?
Logged

Centurion RSA
Offline Offline
Full Member
***
Karma: 0
Posts: 166
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Louis
They show in the list but I get the
Quote
avrdude: stk500_getsync(): not in sync: resp=0x00
error. When I say "does not see" I mean does not communicate. This happens for the programmer as well as the boatloader.

I have been able to get the Uno R3 to program via the bootloader that it comes with but only under Arduino1.0. Arduino-1.0 also does not see any of the AvrIsp programmers

Arduino-0022 does not see anything at the moment.
Logged

Rather people think you to be a fool than you open your mouth and confirm it.

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 485
Posts: 18807
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

They all show in the device manager. The IDE does not talk to them. I get a stk500 timeout. or sync problem.

Can you show them please? Like this:



And then show that you have the corresponding port selected in the IDE (in my case, COM8).
Logged


Centurion RSA
Offline Offline
Full Member
***
Karma: 0
Posts: 166
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nick,
I almost feel that you think I am telling lies. smiley-grin



Here I have the Deumilanove on Com31 and the Uno on Com38. The ISP is on Com35 and Com37.

Sorry I can't capture the menu option in Arduino IDE but I promise they are all there.
« Last Edit: May 15, 2012, 03:23:25 am by Marius » Logged

Rather people think you to be a fool than you open your mouth and confirm it.

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 485
Posts: 18807
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Well the mind boggles at 38 COM ports. Perhaps Windows is at fault. smiley
Logged


Denmark
Offline Offline
Edison Member
*
Karma: 35
Posts: 1073
Happy Hobbyist
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Maybe your comport-numbers are too high.
A quote from the trouble shooting guide:

Quote

On Windows, the COM port assigned to the board may be too high. From zeveland:


"One little note if you aren't able to export and your USB board is trying to use a high COM port number: try changing the FTDI chip's COM port assignment to a lower one.


"I had a bunch of virtual COM ports set up for Bluetooth so the board was set to use COM17. The IDE wasn't able to find the board so I deleted the other virtual ports in Control Panel (on XP) and moved the FTDI's assignment down to COM2. Make sure to set Arduino to use the new port and good luck."


On the Mac, if you have an old version of the FTDI drivers, you may need to remove them and reinstall the latest version. See this forum thread for directions (thanks to gck).


Logged

Centurion RSA
Offline Offline
Full Member
***
Karma: 0
Posts: 166
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Erni,
It wasn't a problem before. I used Com31 for the Arduino from the start. It is only after the Uno R3 installation that things are buggered. I strongly suspect the windows driver.
Logged

Rather people think you to be a fool than you open your mouth and confirm it.

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try the loopback test instructions from this link: http://arduino.cc/forum/index.php/topic,73748.0.html

If this passes, then you can be assured the serial portion of your Arduinos are working as expected.
Logged

Pages: [1]   Go Up
Jump to: