Go Down

Topic: arduino mega 2560 will not upload from computer to board (Read 1 time) previous topic - next topic

sprocive

Evey sketch i have wrote will not upload times out every time i try
dos any one have any suggestions on what i can do to fix this little problem.

i am using windows seven. my computer sees the board. i did down load
arduino 0023 and 0022 and they did not help.

if there is any more info that is needed to help with this pleas let me know.
Sprocive

woody_unreal

You Said
Quote
Evey sketch i have wrote will not upload
Can you load any of the Examples ?

kd7eir

How about telling us the error messages that you are getting?  Show us the sketches that you are trying to load.

Drake D

Check to see in the device manager to see if your board has a device driver. If not when you right click on Arduino Mega in the device manager select properties - you want to tell it you want to browse your computer for the driver and not look on the internet.  It should be in a place like this:C:\Users\Drake411(me)\Downloads\arduino-1.0-windows\arduino-1.0\drivers  And probably Arduino MEGA 2560 maybe you have a rev3.

I just got my XINDA mega 2560 today and was a little miffed it didn't work. Seems to like this driver for uploading sketches. Hope you find my guess useful.

sprocive

this is what i am working on.


// constants won't change. They're used here to
// set pin numbers:
const int buttonPin = 2;     // the number of the pushbutton pin
const int ledPin =  13;      // the number of the LED pin

// Variables will change:
int ledState = HIGH;         // the current state of the output pin
int buttonState;             // the current reading from the input pin
int lastButtonState = LOW;   // the previous reading from the input pin

// the following variables are long's because the time, measured in miliseconds,
// will quickly become a bigger number than can be stored in an int.
long lastDebounceTime = 0;  // the last time the output pin was toggled
long debounceDelay = 50;    // the debounce time; increase if the output flickers

void setup() {
  pinMode(buttonPin, INPUT);
  pinMode(ledPin, OUTPUT);
}

void loop() {
  // read the state of the switch into a local variable:
  int reading = digitalRead(buttonPin);

  // check to see if you just pressed the button
  // (i.e. the input went from LOW to HIGH),  and you've waited
  // long enough since the last press to ignore any noise: 

  // If the switch changed, due to noise or pressing:
  if (reading != lastButtonState) {
    // reset the debouncing timer
    lastDebounceTime = millis();
  }
 
  if ((millis() - lastDebounceTime) > debounceDelay) {
    // whatever the reading is at, it's been there for longer
    // than the debounce delay, so take it as the actual current state:
    buttonState = reading;
  }
 
  // set the LED using the state of the button:
  digitalWrite(ledPin, buttonState);

  // save the reading.  Next time through the loop,
  // it'll be the lastButtonState:
  lastButtonState = reading;
}

this comes up when i try to up load.
avrdude: stk5002_getsync() : timeout communicating with programmer
avrdude: stk500_2_receivemessage() : timeout

let me know if this helps
i do not see my arduino board in my device menu i know i am using
comport1 and my computer is telling me all drivers are updated and working.

let me know what u think.
Sprocive

Go Up