Pages: [1]   Go Down
Author Topic: Can't upload to pro mini, help me troubleshooting!  (Read 998 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey Boys,

I have purchased a clone of pro mini, from here:
http://www.watterott.com/de/Wattuino-pro-mini-5V-16MHz
I also use the SF FTDI Breakout V1.1, which should work fine with it.
However, I have not been able to upload anything to the board. I am using Win7x64, and a USB cable of which I am sure that it is working.
I also have selected the right COM port. I tried uploading using different settings in the Boards-menu. (i.e. duemilanove)
I tried different baudrates, which I changed over the boards.txt file.
I have pushed the reset-button before and while uploading, neither worked.
I did the serial-communication-test, seems good.
Nothing works, I always get the same error:
avrdude: stk500_getsync(): not in sync: resp=0x00

I have uploaded a short video of what happens when I try to upload. First, I plug in the USB-cable and the board and breakout do some blinking. I then click on upload (this is where I move in the video) and the board seems to get resetted successfully, then the breakout RX and TX diodes blink, then nothing.

http://www.youtube.com/embed/S8bwSih4Z-c


What is wrong with that thing??


Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you tried selecting UNO in the Boards menu?

The website, you linked to, said it is using: "Bootloader: Arduino Uno Optiboot"
Logged

Scotland
Offline Offline
Edison Member
*
Karma: 25
Posts: 1314
Have you had your Arduino fix today?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you give a link to the FTDI board - The ones I find have different pin outs to your wiring
Logged

Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Uploading as uno doesn't work either smiley-sad

This is the breakout:

http://www.watterott.com/de/FTDI-Breakout-Reloaded-V11
« Last Edit: May 17, 2012, 02:19:52 pm by steinerlein » Logged

Scotland
Offline Offline
Edison Member
*
Karma: 25
Posts: 1314
Have you had your Arduino fix today?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Change the wires (Maybe put male pins on the Pro) - Your 1 -> 1, 2 -> 2 etc. looks fine, The boards come with the UNO bootloader so this should be your choice in the IDE. Anything more and I'm guessing, If you click upload in the IDE wait until the sketch size shows in the bottom box, then tap reset. that MAY help.
Logged

Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Okay, well. Hardware seems to be fine. I just tried another computer, it worked! I will try to refresh my arduino ide..
Logged

Scotland
Offline Offline
Edison Member
*
Karma: 25
Posts: 1314
Have you had your Arduino fix today?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Glad you got it working. ;-)
Logged

Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yeah, well.. It doesn't work fully yet! What can be the reasons for it not working on my main machine? I redownloaded the arduino program and replaced it, alongside with the preferences.txt file. Not working, same error. Why is that? smiley-sad
Logged

Scotland
Offline Offline
Edison Member
*
Karma: 25
Posts: 1314
Have you had your Arduino fix today?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Are you plugged direct to the PC or on a hub?
Logged

Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

directly or hub, both don't work.
Logged

Scotland
Offline Offline
Edison Member
*
Karma: 25
Posts: 1314
Have you had your Arduino fix today?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm. Maybe low power on output (But the boards should run down to 3.3v) Always connect direct rather than through a hub, also try the other USB ports on the PC. Other than that, Don't know what is happening.
Logged

Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

Stockholm Sweden
Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What OS are you using.In MS windows you had to manuel install driver for USB.



Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am running Win7x64. I thougt about drivers too, but I shouldn't need those, I guess. As I am using a Breakout, all the communication works over Serial communication, doesn't it?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry for begging, but does anyone have any idea, what the cause for my problem might be?
I really don't get it..
Logged

Pages: [1]   Go Up
Jump to: