Pages: [1]   Go Down
Author Topic: Problems with GPRS Shield from SeedStudio  (Read 605 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 0
Posts: 112
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Has anyone used the GPRS shield from Seedstudio. I am having problems even in the first steps mentioned on the wiki website.

BR,
Vik
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 112
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Has any one worked with this shield ?
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 181
So, you want to make something, huh?
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think nobody is replying to your post because you are not specific. Give us some details. What did you try and what is going wrong. smiley-razz
Logged

If you want to meet a beautiful nurse you must be patient.

Offline Offline
Full Member
***
Karma: 0
Posts: 112
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have tried to check the GPRS shield with the first code which is used for giving AT commands to the shield but it gives garbage values on the serial interface display and when i type and enter the AT command, there is no responce. The yellow light is blinking as per given after every three seconds but AT commands seem not to be working. Has anyone faced a similar problem

Code:
//Serial Relay - Arduino will patch a
//serial link between the computer and the GPRS Shield
//at 19200 bps 8-N-1
//Computer is connected to Hardware UART
//GPRS Shield is connected to the Software UART
 
#include <SoftwareSerial.h>
 
SoftwareSerial mySerial(7, 8);
 
void setup()
{
  mySerial.begin(19200);               // the GPRS baud rate   
  Serial.begin(19200);                 // the GPRS baud rate   
}
 
void loop()
{
  if (mySerial.available())
    Serial.write(mySerial.read());
  if (Serial.available())
    mySerial.write(Serial.read()); 
 [\Code]
Logged

Gosport, UK
Offline Offline
Faraday Member
**
Karma: 19
Posts: 3114
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You do have the serial monitor set to 19200 baud?
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 112
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes I have checked it with Putty and the Arduino one as well but I am still getting garbage values
Logged

Global Moderator
UK
Offline Offline
Brattain Member
*****
Karma: 238
Posts: 24371
I don't think you connected the grounds, Dave.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Yes I have checked it with Putty
How did you connect it?
Logged

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Gosport, UK
Offline Offline
Faraday Member
**
Karma: 19
Posts: 3114
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you have the jumper set for software or hardware serial?
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 112
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the jumpers connected to the software serial. I have checked by connecting to hardware serial and checking the SMS code and it is working fine. I am doing the process all over again to check whether I am going wrong anywhere. I am setting the baud rate 19200, parity bit none , flow control none, stop bit 1 and data bits 1 but I get garbage yyyyyy.

Logged

Pages: [1]   Go Up
Jump to: