Go Down

Topic: IDE 1.0.1 Problems with Leonardo, Windows XP and Windows 7 Enterprise (Read 7 times) previous topic - next topic

open_market

I have already commented on this problem, but decided to start a new post specific to IDE 1.0.1, Windows, and Leonardo.

I purchased a new Leonardo, Italain version, at the Maker's Faire last weekend.

With both Windows XP and Windows 7 Enterprise, I get the same error message when trying to run the example program, Blink and using IDE 1.0.1:

Binary sketch size: 4,858 bytes (of a 28,672 byte maxium)
Found programmer: Id = "S*q ": type = p
     Software Version = V. ; Hardware Version = v.
avrdude: error: buffered memory access not supported. Maybe it
isn't
a butterfly/AVR109 but a AVR910 device?

Has anyone experienced similar problems? Has anyone been successful loading programs from Windows to the new Leonardo board using IDE 1.0.1?

                 Thanks - Rick

open_market

Here is the same problem after making sure I set the usb port and ran the upload in verbose mode:

My Leonardo is on COM4 - which I set in the IDE 1.0.1:

Binary sketch size: 4,858 bytes (of a 28,672 byte maximum)
Forcing reset using 1200bps open/close on port COM4
PORTS {COM1, COM3, COM4, } / {COM1, COM3, COM4, } => {}
PORTS {COM1, COM3, COM4, } / {COM1, COM3, COM4, } => {}
PORTS {COM1, COM3, COM4, } / {COM1, COM3, COM4, } => {}
PORTS {COM1, COM3, COM4, } / {COM1, COM3, COM4, } => {}
PORTS {COM1, COM3, COM4, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, } => {}
PORTS {COM1, COM3, } / {COM1, COM3, COM4, } => {COM4, }
Found Leonardo upload port: COM4
C:\Downloads\arduino\arduino-1.0.1\arduino-1.0.1-windows\arduino-1.0.1\hardware/tools/avr/bin/avrdude -CC:\Downloads\arduino\arduino-1.0.1\arduino-1.0.1-windows\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega32u4 -cavr109 -P\\.\COM4 -b57600 -D -Uflash:w:C:\DOCUME~1\Rick\LOCALS~1\Temp\build6743039881646635356.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Downloads\arduino\arduino-1.0.1\arduino-1.0.1-windows\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM4
         Using Programmer              : avr109
         Overriding Baud Rate          : 57600
         AVR Part                      : ATmega32U4
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PA0
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    10     8    0 no       1024    8      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : butterfly
         Description     : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .avrdude: Send: . [1b]
avrdude: Send: S [53]
avrdude: Recv:

avrdude: Recv:
avrdude: Send: V [56]
avrdude: Recv:
avrdude: Send: v [76]
avrdude: Recv:
avrdude: Recv:
avrdude: Send: p [70]
avrdude: Recv:
Found programmer: Id = "¨ÿ""; type = m
    Software Version = E.


I'm unable to use this incredible micro controler with the IDE 1.0.1 - where do I go from here?

               Thanks - Rick

zeveland

Hmm...  Yep, you do seem to have the correct COM port set (as seen by the fact that the IDE restarts the board as expected). 

I don't have a ready explanation but do have a few more questions:

You say you've tried it on two flavors of Windows.  Was that on two different physical machines or are one or more of the OSes virtualized? 

Is there a USB hub or KVM between the Leonardo and the computer or is the Leonardo plugged directly to one of the computer's own ports (the "root hub")?

If you manually reset the board does the LED "breathe" for several seconds?  Once it stops breathing does it start blinking with a period of two seconds?

Do you have any shields or other electronics connected to the board?

Can you try uploading and manually resetting the board?  Time it so you hit the reset button when "Compiling sketch..." in the status bar is replaced with "Uploading...".


open_market


You say you've tried it on two flavors of Windows.  Was that on two different physical machines or are one or more of the OSes virtualized?

Two different physical machines, one with USB 2.0, and one with USB 1.0.


Is there a USB hub or KVM between the Leonardo and the computer or is the Leonardo plugged directly to one of the computer's own ports (the "root hub")?


Plugged directly to the USB port.

If you manually reset the board does the LED "breathe" for several seconds?  Once it stops breathing does it start blinking with a period of two seconds?

No.

Do you have any shields or other electronics connected to the board?

No

Can you try uploading and manually resetting the board?  Time it so you hit the reset button when "Compiling sketch..." in the status bar is replaced with "Uploading...".

I tried this and got the same error message.

Thanks so much for taking the time to look into this. I'm excited to start using the Leonardo - feels close...

                              - Rick

Go Up