Pages: 1 [2]   Go Down
Author Topic: Tutorial ARDUTEKA - Matriz LED Bicolor + 74CH595  (Read 16505 times)
0 Members and 1 Guest are viewing this topic.
Forum Moderator
Zaragoza
Offline Offline
Newbie
*****
Karma: 0
Posts: 16
Aprende a desarrollar por ti mismo!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bueno, vamos al tema, el chip se llama 74HC595 como bien dices.
¿Diferencias entre N y D? Buscamos en google el datasheet del 74HC595 -> http://www.nxp.com/documents/data_sheet/74HC_HCT595.pdf
Página 2, apartado 4 -> N es empaquetado DIP16 y D es empaquetado SO16, hmm, ¿Cual será el que necesitemos?

Busquemos en el pdf por DIP16 y SO16 para ver que tipo de empaquetado es cada uno y poder saber cual queremos.
Página 17, empaquetado SO16, vaya, es de montaje superficial, probablemente no sea el que quieras ni lo tengan en la tienda de barrio de electrónica.
Página 16, empaquetado DIP16, hey! Es la cucaracha de toda la vida! Me servirá para montarlo en un protoboard smiley-grin

No es muy recomendable realizar el montaje tal cual está expuesto, ya que se puede llegar a cuadruplicar el límite de corriente de los pines de Arduino, tanto de los de entrada/salida como el de GND.

Por otra parte, el esquemático es erróneo, ya que el pin Q7' del primer 74HC595 hay que conectarlo al pin DS del segundo 74HC595, no al Q7'.

Un saludo smiley-wink

Hola Chiva!

Es cierto, las imágenes están mal, en el tutorial comento que se debe conectar el Q7 del primero al DS del segundo, pero a la hora de hacer el esquema me colé.. Lo modifico en breves!!

El tema de la corriente en las salidas de Arduino, supongo que te refieres al color que está conectado directamente a Arduino tomé como referencia el tutorial de Arduino.cc http://www.arduino.cc/playground/Main/DirectDriveLEDMatrix pero de todas maneras, revisaré en cuanto pueda todo el circuito y si lo modificaré, ok?

Gracias por el feedback! Cada día voy aprendiendo un poco más! smiley-wink

Un saludo.
Logged

Aprende a desarrollar por ti mismo!!

@Arduteka
Facebook

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos..

Estamos haciendo un proyecto para una asignatura de FP.
Manejamos las anodos (filas) con un 74hc595 y las columnas (catodos) con 74hc595 también
Queremos usar un transistor PNP BC557 para atacar a cada fila y tener una mayor intensidad lumínica y proteger las salidas del arduino.
El problema parece ser que no conmuta del todo bien ya que al mostrar un caracter, ilumina la fila entera.
Aqui sin usar el transistor, como debería mostrar el mensaje

Con el transistor atacando la fila 2
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola, me gustan vuestros proyectos y me gusta trastearlos. Vereis tengo una duda, vuestro proyecto de la matriz es con cátodo común, yo la que tengo es con ánodo común. Mi pregunta es: que modificaciones tengo que hacer a la hora de programar y de hacer el montaje. Espero que podais ayudarme pues estoy empezando con arduino y es un mundo muy amplio. Gracias de antemano, recibid un cordial saludo.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola amigo encontraste las modificaciones ala programacio. Para que trabaje con un display 8x8 bicolor de anodo comun? Es que no me trabaja, y me urge agradeseria ayuda porfavor
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos.. miren lo que pasa es que en base a este proyecto he estado tratando de mejorarlo y ampliarlo y me encontre con que al ampliarlo a una matriz de 6x40 osea aumentar dos matrices de leds mas al circuito tambien le aumente dos registros de desplazamiento como verán el figura.. el código igual lo modifique.. pero tengo un problema .. cuando ya lo enciendo en proteus para correr la simulación no hace nada solo se muestran una cadena de símbolos raros y no se encienden las matrices pares osea se encienden las primeras 8 columnas, las siguientes 8 no se encienden, luego las siguientes si....y así .. quisiera que me ayuden verificando el código ... a ver si me he equivocado en algo ... y tambien le den  una revisión al circuito.

PT: adjunto código y el esquema en proteus ..

saludos

 smiley

* letrero.PDF (214.37 KB - downloaded 53 times.)
* letrero.ino (7.52 KB - downloaded 34 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos, he estado leyendo su tuto y esta buen pero yo no tengo la matriz de leds 8x8 solo de 7x5 queria a ver si se puede hacer lo que ustedes hacen pero uniendo dos matriz de led 7x5 ,y si pueden darme la nocion de como seria la conexion y progrmacion . gracias de antemano
Logged

Pages: 1 [2]   Go Up
Jump to: