Go Down

Topic: Problema test ks0108! Aiutooooo ! (Read 1 time) previous topic - next topic

jakub999

Ciao a tutti!
Oggi ho deciso di testare il mio display grafico con controllo ks0108.
Per fare ciò, ho scaricato la libreria ( http://www.arduino.cc/playground/Code/GLCDks0108 ), ho caricato lo skatch di esempio sul mio arduino... e sorpresa, si vede tutto nero. L'unica cosa che funziona è la regolazione della luminosità!  =( =( =( =(
Qualcuno saprebbe come aiutarmi???
Grazie
:) :)

iw1evm (Tecno)

Io ho usato la stessa libreria e funziona tutto correttamente, controlla bene tutti i collegamenti perchè sono tanti e si puo sbagliare. avevo trovato un link in cui spiegavano i vari collegamenti per i diversi arduino(uno,mega ....) ma adesso non lo trovo.

jakub999

Ho seguito il tuo consiglio ed ho rifatto tutti i collegamenti, ma riesco soltanto a cambiare il contrasto..
sembra quasi che l'arduino non riesca a comunicare bene con il display...

iw1evm (Tecno)

Ciao il tuo lcd è per caso questo "g64128w01ntn00" della cct perche se lo è segui un mio post precedente.

jakub999


jakub999

Ho rifatto tutti i collegamenti, ed ho provato a caricare lo skatch di esempio che viene fornito con la libreria...
ma il risultato è questo.... http://imageshack.us/photo/my-images/213/fotoau.jpg/  (scusate per la foto storta)
  :0
aiutatemi, non so più cosa fare!!!
grazie
:)

PaoloP

Qui c'è una versione aggiornata della libreria --> http://arduino.cc/forum/index.php/topic,56705.0.html

jakub999

Ora sembra che qualcosa si muova, ma ci sono solo dei segni incomprensibili
:smiley-roll-sweat:

PaoloP

#8
May 31, 2012, 06:48 pm Last Edit: May 31, 2012, 06:51 pm by PaoloP Reason: 1
Ho letto nel topic del link che anche altri utenti hanno avuto il tuo stesso problema.
Secondo me è una questione di collegamenti, ho visto che esistono varie versioni, dalla A alla D, in base al modello.
Prova a riverificare soprattutto con la serigrafia sul retro del display.

C'è anche questo sul sito della Sparkfun --> http://forum.sparkfun.com/viewtopic.php?p=71041

AnTrea

dai un occhio qui: http://arduino.cc/forum/index.php/topic,49963.0.html

NOTA: il post che ti ho linkato è relativo al 107 che ha solo un paio di pin invertiti, ma per il resto (se non ricordo male) è molto simile
Arduino, MODs e DIY: blackstufflabs.com

jakub999

Il mio display è un Sparkfun LCD-00710CM e perciò ho seguito i collegamenti della colonna A http://www.arduino.cc/playground/Code/GLCDks0108, ma continua a non funzionare
:smiley-roll-sweat:

acron

ho avuto anche io lo stesso problema.....dopo aver controllato e rifatto i collegamenti decine di volte ho scoperto che avevo saldato male la strip. ;)

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy