Go Down

Topic: useing older avrdude to fix Mega2560 R3 (Read 784 times) previous topic - next topic

I'm one of the Mega2560 users who had to replace the IDE 1.0 avrdude.exe and avrdude.conf files with ones from a previous version (0022 in my case).
Mega2560 was hanging almost every time, now never hangs.

My question is, are there any known problems caused by useing the older avrdude?
In other words, is it going to come back to haunt me?

Another question. Since the issue was known in IDE 1.0, I had hope that it would be fixed in IDE 1.0.1.
Will this be addressed in the next IDE version?

Bob

I meant to post this in the "Other Software Development" section.
If the moderator wold move it, I would be grateful.
Bob

Coding Badly


I think this is a more appropriate section.  What you have described strikes me as essentially a bug.

Has the problem been reported on the issues list?
http://code.google.com/p/arduino/issues/list

Louis Davis

Yes, the issue has already been reported:
http://code.google.com/p/arduino/issues/detail?id=806

The issue was introduced when Avrdude 5.11 was picked up in 1.0
The custom version of Avrdude, in the previous versions of Arduino, would toggle DTR for the stk500v2 protocol use on Mega2560.

Thanks Louis.
I had poured over the list, but didn't find it.

I see at the bottom of the issue report that there is a new avrdude.exe attached.
I shall try it.

Would be nice to see this in the troubleshooting guide.

Bob

Go Up