Go Down

Topic: [SOLVED] stk500_getsync() (Read 444 times) previous topic - next topic

ozkaa

Jun 03, 2012, 07:17 pm Last Edit: Jun 08, 2012, 07:34 pm by ozkaa Reason: 1
Hi All,
I am having a problem with my Arduino Pro Mini clone (Atmega328) Duemilanove

When uploading a sketch I receive either the error 0x82 or 0x83 on Linux (the LED's start flashing when trying to upload).
When uploading through Windows I get a 0x02 error (LED's also flash normally)

The main LED is lit and there is one blinking LED - about every 2 seconds, which according to what I read is that the bootloader is working.

There is nothing connected to the board, just the FTDI cable which provides 6.4V to the board (max12).
I tried the reset button trick and without
I changed the Baud rate from various 9600 to 115200
I run on Linux (FC16) with a serial-USB cable, but also tried on native Windows7 and WinXP through virualization.

I used avrdude directly I tried several commands like
/usr/bin/avrdude -C/etc/avrdude/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P/dev/ttyUSB1 -b57600 -D -Uflash:w:/tmp/build8973257987213556989.tmp/BareMinimum.cpp.hex:i

changing the baud values here and also replacing -cstk500v1 with -carduino

I believed I have tried every possible configuration and all ended up with these error(s)....

Although if I change the speed to higher values i get the error 0xf0 or 0xff back.

Anybody ever encountered anything like this? do I need to get an AVR programmer?

Thanks in advance
Oscar


ozkaa

I managed to get the board working by connecting an UNO R3 to the reset pin + 11,12,13 and flash a new bootloader unto it (OptiBoot).
Then I also was able to upload the blink light example using upload using programmer.

Remember that the new board will be identified as a Arduino UNO since the bootloader got changed.

Hope it helps somebody with the same issue?

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy