Pages: [1]   Go Down
Author Topic: sensor data via Cat6 / RJ45 / breakout board  (Read 2040 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello all,

I'm trying to feed sensor data from multiple sources into an Arduino via network cables (Cat6). These are currently plugged into an RJ45 connector + breakout board at both ends. Here are the parts:

http://www.sparkfun.com/products/8915
http://www.sparkfun.com/products/643
http://www.sparkfun.com/products/716

The trouble is I'm unsure how to get a clean signal. When I feed one (photoreflective) sensor output into the Arduino (A0 input), the signal is clean. When I feed it into one of the Ethernet lines (say orange), and take the output at the other end to feed it into the Arduino, the signal is all over the place.

Is this noise caused by the cable picking up my PC's electromagnetic interference? Or is the signal being encoded somehow? What is the proper way to hook up the sensor output to the network cable? For example, do I have to have one line for signal and another (matching color) for ground? Is the cable powered through the sensor output, or should I be powering it at the Arduino end?

A friend suggested I stick with regular shielded coaxial cable, one per sensor output. But I was hoping to get 4 sensor inputs (1 per cable pair) running through a single network cable to simplify.

Anyway, any clarification would be a huge help at this point. I'm quite new to this. Thank you for your patience!
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 20
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

HI,
how long is a cable, what exactly is your sensors (name, type, results signal). How look your schematic ?

I normally use 1-wire sensors over UTP cable without any problem.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Here are the sensors I'm using (8 in all):
http://www.sparkfun.com/products/246

The cables will extend around 10 feet.

UTP looks to be pretty much the same as Ethernet/Cat6; I'm not sure, but the Cat6 cable I have may be unshielded too, which might be the reason I'm getting interference (being next to a PC).

I don't have a schematic; the QRD1114 circuits work though, and I'm temporarily testing by sending the sensor outputs to the Arduino via audio cable, which also works.

Still, is it a simple matter of connecting a sensor output to one of the Cat6 inputs, then taking that at the other end of the Cat6 and feeding it into the Arduino analog in? Because right now that's not working.

 


Logged

nr Bundaberg, Australia
Offline Offline
Tesla Member
***
Karma: 126
Posts: 8474
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you have a common ground between the sensor and the Arduino?

______
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Rob,

At the moment yes: since I'm working off the breadboard, all sensors are going to the GND pin on the Arduino. But the installation will ultimately be designed so that each sensor operates off its own battery power (each one will be in a separate location in the hall), so each one will have its own ground.
Logged

Ayer, Massachusetts, USA
Offline Offline
Edison Member
*
Karma: 53
Posts: 1835
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I believe you still need to wire all grounds together.  So one of the wires in your cat6 needs to be the common ground.  Also, I believe you said that you were using unshielded cable.  You probably should get proper shielded cables as well.
Logged

nr Bundaberg, Australia
Offline Offline
Tesla Member
***
Karma: 126
Posts: 8474
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, unless you go for isolated interfaces (optocouplers etc) you need common grounds between all devices.

______
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So let me see if I've got this. Taking three arbitrary wires on the Cat6, wire 1 supplies power to sensor from the Arduino, wire 2 transmits sensor data back to Arduino, and wire 3 acts as common ground. Do I have that right?

And yes, making sure the cable is shielded will help. Thanks for the feedback.
Logged

nr Bundaberg, Australia
Offline Offline
Tesla Member
***
Karma: 126
Posts: 8474
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Do I have that right?
Yep, not that any of this helps with the current problem, have you connected the shield to ground to see if that helps?

______
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Rob, if you mean the Cat6 shield, the answer is not yet - though since I'm using the RJ45 connectors I was hoping to avoid cutting the cables open, or is that what you mean?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 20
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

According, all information you write it spouse to be problem with common ground. Please check wiring diagram for 1-Wire system by Hobby Boards https://www.hobby-boards.com/store/pages.php?pageid=11 , and try to reimplement for your purposes.
Logged

nr Bundaberg, Australia
Offline Offline
Tesla Member
***
Karma: 126
Posts: 8474
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes I was asking if you had connected the shield yet, if you have to cut the cable that might be an issue though. Maybe scrape some insulation off just to try it.

______
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi all, just following up.

I've been looking into alternatives to Ethernet cables, specifically using RS-485 / MAX 485 to convert incoming analog sensor data from the 8 sources I mentioned. From what I've read, this will greatly increase the distance over which I can transmit.

But in order to cut down on cable clutter, I'm still wondering what the best cable option would be. Obviously something shielded with low impedance. Some kind of twisted pair? Shielded audio cable? Coaxial with BNC connectors? What gauge? Which then raises the question of which perfboard terminals and connectors I'd need. The choices are a little bewildering at this stage, so if anyone has done this before, I am all ears.

Again, I am estimating the cable distance, one-way, to be around 20-25 feet. And I'm guessing I'd need something like 2 cables with at least 4 lines each, not counting power and ground conductors.

Thank you so much!
Logged

nr Bundaberg, Australia
Offline Offline
Tesla Member
***
Karma: 126
Posts: 8474
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I'm still wondering what the best cable option would be.
I can see no reason not to use Cat5/6 cable. (Sorry about the double negative)

______
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Pages: [1]   Go Up
Jump to: