Go Down

Topic: newb needing help compiler fails in version 1.01 (Read 2723 times) previous topic - next topic

globalgtltd

Hi everyone,
ive spent the day trying to figure out all the steps to control a rep rap using the Arduino 2560mega, a ramps 1.4, and marlin software.

My actual project is to replace the non functioning control system on my Stratasys FDM8000. ive spent 2 days with this machine (ive owned it for 8 years and used it on several occasions but not in the last 6 months, i also have a second machine as a spares source) and im sure that the 8025 control chip has failed, its not available so as i totally replaced the control system on my cnc router and been using that daily for the past 5 years i figure i can do a similar update to the Stratasys.

back to the subject:
Ive bought a commercially made Ardunio 2560 and a ramps 1.4 board package including 5 stepper drivers.
im running win7 home 64 bit edition.
so i followed the instal guide, compiled and uploaded and got the blink program working and discovered you have to unplug it to stop it.
happy with this stage i added the ramps and tried to upload marlin, it failed in the compile section.
I went back to the start and re-did the blink and after pressing the reset button that worked again, so i then tried the 0022 software and that compiles the marlin program fine, ive tried the 0023 and that works to.

here is the fail code from 1.0.1: (ive deleted the first part of the line showing my folder path as thats not relevant)

c:/arduino-1.0.1/hardware/tools/avr/bin/../lib/gcc/avr/4.3.2/../../../../avr/lib/avr6/crtm2560.o: In function `__vector_default':
(.vectors+0xb0): relocation truncated to fit: R_AVR_13_PCREL against symbol `__vector_44' defined in .text section in
c:/arduino-1.0.1/hardware/tools/
avr/bin/../lib/gcc/avr/4.3.2/../../../../avr/lib/avr6/crtm2560.o

now i can sort of follow what it is saying but the thing is it means nothing to me as my knowledge is limited, but im good at researching and finding the result normally.
any help greatly appreciated
Alex

Coding Badly


globalgtltd

Hi
yes it will compile the blink program and upload it fine.
I have also tried the 1.0 version and that works fine, it appears only to be with 1.0.1 but it is not limited to marlin i have tried a few others to and they fail, the test programs such as blink do work.
I have read somewhere about using .ini versions of the .pde files but haven't found a .ini download?

Coding Badly


Huh.  You have bumped into a strange problem.  As far as I can tell, the compiler and linker are the same version.  However, crtm2560.o is different.  That implies a different version of Libc was included with Arduino 1.0.1.  I cannot find any mention of the change in the release notes.

I believe the R_AVR_13_PCREL error is specific to smaller AVR processors.  Which indicates that crtm2560.o was not built correctly.

I suggest upgrading to a more recent toolset...
http://arduino.cc/forum/index.php/topic,37965.msg281176.html#msg281176

SurferTim

Quote
I suggest upgrading to a more recent toolset...

The same goes for the Arduino crew. Isn't avr-gcc v4.3.2 a bit old?
And what version of avr-libc is being used now?


mellis

Do you have the same problem with Arduino 1.0?  Testing it would help isolate the changes that caused this problem to occur.

For example, in Arduino 1.0.1, we added the "--relax" flag to the linker options, which helps with large programs (http://code.google.com/p/arduino/issues/detail?id=729).  It's possible that the issue you're seeing is a side effect of that change, for example.

TwinD


Do you have the same problem with Arduino 1.0?  Testing it would help isolate the changes that caused this problem to occur.

For example, in Arduino 1.0.1, we added the "--relax" flag to the linker options, which helps with large programs (http://code.google.com/p/arduino/issues/detail?id=729).  It's possible that the issue you're seeing is a side effect of that change, for example.


FYI I had the exact same problem and using Arduino 1.0 fixed it.

Dr_Ugi

I have had this same issue today - compiling for ATtiny85 using Arduino Tiny 0015 and Arduino 1.0.3.  It appears to relate to compiled sketch size - any arbitrary deletion from my code would make it compile but a few bytes bigger and it won't.  Cut-off was around 4K.

Down-grading to 0022 or 1.0 did not help.
Down-grading to Arduino Tiny 0012 did not help either.

However, up- (or down- or sideways-, I'm not sure) grading to WinAVR20120110 from here: http://sourceforge.net/projects/winavr/files/  seems to have fixed it.

If you need assistance with the process, this is a very useful thread:

http://arduino.cc/forum/index.php/topic,37965.msg281176.html#msg281176

Ugi


rexinthecity


Do you have the same problem with Arduino 1.0?  Testing it would help isolate the changes that caused this problem to occur.

For example, in Arduino 1.0.1, we added the "--relax" flag to the linker options, which helps with large programs (http://code.google.com/p/arduino/issues/detail?id=729).  It's possible that the issue you're seeing is a side effect of that change, for example.


I've run into this same issue and using 1.0 fix it. Is there a way to remove the --relax flag from my local copy of 1.0.1 or later?

Go Up