Go Down

Topic: [SOLVED] Arduino IDE 1.01 "An error occurred while starting the application." (Read 12 times) previous topic - next topic

szary

I found a walkaround on arduino IDE code.google site. Get the 1.0.1 RC2 IDE (http://files.arduino.cc/downloads/arduino-1.0.1-rc2-windows.zip) and replace lib/pde.jar from 1.0.1 with RC2 version. Works fine in my case.

JimboZA

I sometimes get that message with 101, sometimes not, which in itself is a bit of an issue- intermittent problems are notoriously tricky to deal with.

BUT, even when I do get the error message, it seems to start up and run fine anyway!
Roy from ITCrowd: Have you tried turning it off an on again?
I'm on LinkedIn: http://www.linkedin.com/in/jimbrownza

mellis

I think this is a problem with the Polish translation.  It included a translation of an internal string (used as a Date format); the translation makes the string invalid and there's an exception on startup.  You could try putting your computer into a language other than Polish or editing the editor.languages.current preference in your preferences.txt file (e.g. setting it to "en").

See: http://code.google.com/p/arduino/issues/detail?id=942

rekram

@mellis  big thanks for you and everyone who tried to help, setting
Code: [Select]
editor.languages.current=en
fixed the problem! :D

I have English version of Windows, but I use Polish keyboard and regional settings, probably that's why Arduino IDE try to set Polish language.
I added [SOLVED] to the topic name.

Marek

Solution comming form http://rc-fpv.pl/viewtopic.php?p=105060

there is a problem with java engine initiation with languages/locales other than en/US
Solution is: create a.cmd file with one line:
java\bin\java -Duser.language=en -Duser.country=US -classpath "lib;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base

and start Arduino by calling a.cmd - not arduino.exe

addded to Issues - ID# 952

Go Up