Pages: [1]   Go Down
Author Topic: [SOLVED] Arduino IDE 1.01 "An error occurred while starting the application."  (Read 11516 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!
I have Win 7 x86, Arduino IDE 0023 is working great, but the last version has problem to open.
I see this error, and nothing happens. I have java 7 Rountime installed, but I think it doesn' matter because Arduino has his own java in folder.

Any suggestions?

« Last Edit: June 07, 2012, 12:24:29 pm by rekram » Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

There has been some indication that a corrupt preferences.txt file can prevent the IDE from launching.

Try deleting your preferences.text file.
It can be found in the following location, depending on what version of Windows you have:

c:\Documents and Settings\<USERNAME>\Application Data\Arduino\preferences.txt (Windows XP)
c:\Users\<USERNAME>\AppData\Roaming\Arduino\preferences.txt (Windows Vista\Windows 7)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I removed but didn't help
Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Where do you have Arduino 1.0.1 installed?

For example, I have all of my versions of Arduino installed in these locations:
C:\arduino\arduino-1.0\
C:\arduino\arduino-1.0.1\

What is the error message your are seeing?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I have exactly the same problem. I just tried IDE 1.0 and it's working great. When I'm trying to run 1.0.1 after couple of seconds I'm getting this:

Launch4j
An error occurred while starting the application.

I've run "arduino.exe --l4j-debug" command, and the results are (seem to be fine):

CmdLine:   D:\arduino-1.0.1\arduino.exe --l4j-debug
WOW64:      yes
Working dir:   D:\arduino-1.0.1\.
Bundled JRE:   java
Check launcher:   D:\arduino-1.0.1\java\bin\javaw.exe (OK)
Add classpath:   lib\pde.jar
Add classpath:   lib\core.jar
Add classpath:   lib\jna.jar
Add classpath:   lib\ecj.jar
Add classpath:   lib\RXTXcomm.jar
Launcher:   D:\arduino-1.0.1\java\bin\javaw.exe
Launcher args:   -Xms128m -Xmx128m -classpath "lib;D:\arduino-1.0.1\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base
Args length:   156/32768 chars

IDE 1.0 works great from "D:\arduino-1.0"

Edit: Windows 7 Ultimate x64
I just tried to run 1.0.1 on second machine (but still Windows 7 x64) but I'm having the same error smiley-sad
« Last Edit: June 06, 2012, 01:14:34 am by szary » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I found a walkaround on arduino IDE code.google site. Get the 1.0.1 RC2 IDE (http://files.arduino.cc/downloads/arduino-1.0.1-rc2-windows.zip) and replace lib/pde.jar from 1.0.1 with RC2 version. Works fine in my case.
Logged

Johannesburg. UTC+2
Offline Offline
Faraday Member
**
Karma: 99
Posts: 4430
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I sometimes get that message with 101, sometimes not, which in itself is a bit of an issue- intermittent problems are notoriously tricky to deal with.

BUT, even when I do get the error message, it seems to start up and run fine anyway!
Logged

The Elders of the Internet know who I am
I'm on LinkedIn: http://www.linkedin.com/in/jimbrownza

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I think this is a problem with the Polish translation.  It included a translation of an internal string (used as a Date format); the translation makes the string invalid and there's an exception on startup.  You could try putting your computer into a language other than Polish or editing the editor.languages.current preference in your preferences.txt file (e.g. setting it to "en").

See: http://code.google.com/p/arduino/issues/detail?id=942
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@mellis  big thanks for you and everyone who tried to help, setting
Code:
editor.languages.current=en
fixed the problem! smiley-grin

I have English version of Windows, but I use Polish keyboard and regional settings, probably that's why Arduino IDE try to set Polish language.
I added [SOLVED] to the topic name.
« Last Edit: June 07, 2012, 12:25:32 pm by rekram » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Solution comming form http://rc-fpv.pl/viewtopic.php?p=105060

there is a problem with java engine initiation with languages/locales other than en/US
Solution is: create a.cmd file with one line:
java\bin\java -Duser.language=en -Duser.country=US -classpath "lib;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base

and start Arduino by calling a.cmd - not arduino.exe

addded to Issues - ID# 952
Logged

South Carolina
Offline Offline
Newbie
*
Karma: 1
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

There has been some indication that a corrupt preferences.txt file can prevent the IDE from launching.

Try deleting your preferences.text file.

Worked for me!

It had been starting very slow - after a wait of 1 min or so. Now starts after 5 sec.  The only preference I recall changing is "Use external editor".  Running 1.0.3 here under XP. I re selected "use external editor" and it is still OK.  Will keep an eye on it. 

 Thanks!!!
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 34
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've just deleting the file and it works for me!

Thanks a lot
Logged

Pages: [1]   Go Up
Jump to: