Go Down

Topic: Fil pilote du radiateur (Read 1 time) previous topic - next topic

Cow faith

Bonjour à tous,

Je suis en train de réaliser ma carte de contrôle du fil pilote mais je bute non pas sur la commande mais sur le radiateur! Il me semble que le fil pilote déconne un peu, j'aurais voulu avoir votre avis là-dessus pour savoir si le problème vient de là. C'est un convecteur 'equation' avec deux boutons à rotation : un avec "Eco / Confort / Arret / Prog" et l'autre avec les chiffres 1->6.

-> Sans rien mettre sur le fil pilote j'ai du 230V entre le fil pilote et le neutre
-> Quand je branche la phase sur le fil pilote je ne perçois aucuns changements, faut-il attendre plusieurs minutes? Il faut bien se mettre sur Prog?
-> Avec un diode 1N4007 entre la phase et le fil pilote, dans un sens comme dans l'autre je ne vois aucune variation entre le mode Conf et Prog.

Est-ce que c'est un fonctionnement normal? Faut-il faire autre chose? Il existe d'autre système de fil pilote que le '6 ordres'?
Je vous remercie.



icare

Bonjour

Pour utiliser le fil pilote il faut que bouton de ton radiateur sur en mode "PROG".
Les commandes par fil pilote se traduisent par l'envoi de demi-période (>0 ou <0), de la phase, rien ou encore de trains d'impulsions.
Tu trouveras très facilement sur le net les explication qui vont bien, par exemple : http://laurent.deschamps.free.fr/fil_pilote/d0e3db5e-3f72-4cf5-914c-93b4c5b3fb01.pdf
@+
2B OR NOT(2B) = FF
Arduino 1.0.5 + Notepad++ (sous Linux Fedora et/ou Windows)

Brisebee

Bonjour,

Pour utiliser le fil pilote il faut que bouton de ton radiateur sur en mode "PROG".


ou encore en mode "Auto" selon les radiateurs => tu devrais trouver ces informations sur la notice du radiateur.

Si le fil pilote est en l'air et que tu es en mode Automatique, tu ne devrais rien mesurer comme tension.

@+

Cow faith


A mince j'ai du 230V en mode PROG alors que le fil pilote est en l'air :(
A priori c'est une panne?
Je n'ai plus qu'à ouvrir le radiateur pour chercher...

Cow faith

Bonjour à tous,

Je viens juste conclure en partageant mon expérience suite aux tests.
Le fil pilote débitait bien du 230V~ quelque soit le mode dans lequel était le radiateur (eco, conf, prog). Du coup j'en ai conclus qu'il était défectueux, et j'ai sectionné le fil. Cependant je souhaitais vraiment contrôler mon convecteur, je l'ai donc ouvert.
Je me suis dit : et si je réalisait un interrupteur électronique sur la patte de commande du triac qui contrôle la résistance chauffante?
J'ai donc trouvé le triac (facile à trouver, c'était le seul composant collé à un dissipateur de 20 cm de large avec de la pâte thermique :D). 3 pistes arrivait donc deux faisant 1cm de large. J'ai donc coupé et remplacé la résistance (54ohm) de la 3ièm piste de la gate du Triac (celle qui avait une taille normale), et j'ai soudé deux fils à la place.
Résultat à l'oscillo : une impulsion de 25V toute les quelques millisecondes (ça fait du 0,5A en impulsion  :)).
J'ai ensuite branché mes deux fils sur la sortie de mon optotriac MOC3041 en série avec la même résistance (l'opto à une chute de tension de 1V, ça changera pas grand chose au 25V).
Du coup ça marche nickel, le circuit est isolé et contrôlable à faible courant avec une Arduino.

Et merci pour l'aide amis du forum ;)

Go Up