Go Down

Topic: auto contrast display. (Read 521 times) previous topic - next topic

jonisonvespaa

Jun 07, 2012, 07:42 pm Last Edit: Jun 07, 2012, 07:50 pm by jonisonvespa Reason: 1
hi,
ive just brought a 20 4 display just noticed thats its an auto contrast display, i cant get it to go, its set us as "hello world" just wondering if i should feed +5v into V0 as thats where the wiper went?
thank you

ive just noticed a very very very  faint, hello world, how can wind it up if its auto contrast??

vovpvi

What do you mean with an "auto-contrast"?

You always have to adjust the contrast with a potentiometer. You find it in the datasheet of your lcd.

jonisonvespaa

it says on the back,
please note, the contrast in this display is automatic and so pin 3 need not be connected. if an adjustment trimmer is provided it will have no effect

floresta

Quote
...just wondering if i should feed +5v into V0 as thats where the wiper went?

Typically there is about 1/2 volt on pin 3 when the contrast is set correctly so +5V would not be a good choice.

Quote
it says on the back,
please note, the contrast in this display is automatic and so pin 3 need not be connected. if an adjustment trimmer is provided it will have no effect

There should be some sort of photosensitive device on the board to activate the 'automatic' function.

You are asking us to diagnose an unknown device and you are feeding us the clues one by one.  Why don't you just give us all the information that you have.  A photograph of each side of the board would be helpful.

Don

jonisonvespaa

thanks for the help, i didnt have pins 15,16 connected. all ok now

Go Up