Go Down

Topic: Confundido, alimentado por USB funciona, con bateria de 9V no (Read 1 time) previous topic - next topic

Hola, he hecho este proyecto de recibir señales de un PIR a arduino:

Code: [Select]
int pirPin = 2;
int ledPin = 13;

void setup(){
 Serial.begin(9600);
 pinMode(pirPin, INPUT);
 pinMode(ledPin, OUTPUT);
 digitalWrite(pirPin, LOW);

}

void loop(){
if(digitalRead(pirPin) == HIGH){v
 digitalWrite(ledPin, HIGH);
}

if(digitalRead(pirPin) == LOW){      
 digitalWrite(ledPin, LOW);
}

}



Funciona perfectamente con el cable USB alimentando la placa Arduino, pero cuando uso una bateria de 9V no funciona bien, así que intuyo que por la energía es donde anda el problema. No soy electronico, sino mas bien curioso y no se que pasa.

Alguien sabrá que sucede y como solucionarlo?

La batería de 9V esta usada?

Un truquito que utilizo yo para saberlo es el LED del power de la placa de arduino, cuando cambias de USB a alimentación externa bajara el brillo y eso quiere decir que le falta "chicha" a la alimentación.

Un saludo!

Esta relativamente nueva.

Y con el truco suyo pues se ve de la misma intensidad, creo que tiene que ver con los mAh, el usb da 500mAh pero no se la bateria de 9v, ni se menos como corregir ese error, si fuera el caso  =(

Gracias por su respuesta!

flico

Trabajando en ...

    * Control Domotico (En montaje ...)
    http://casitadomotica.blogspot.com/
 

[url=https://bitbucket.org/fmalpartida

El truco es algo rudimentario y si no hay mucha carga en el circuito ni se inmutara la LED :smiley-red: jeje

Así que es extraño ya que una pila de 9V si es nueva o casi puede mover servos y un PIR no tiene un consumo muy grande.

Si puedes poner el esquema de como conectas el PIR al arduino, aunque si por USB funciona y por la alimentación externa no algo raro :smiley-fat:

Por otra parte me fijado en el código y veo que hay una "v" perdida por hay pero eso te tendría que dar error en compilar, y deduzco que al sido al pegar el código o algo por el estilo, solo lo digo por si acaso.

Quote
[...]

void loop(){
if(digitalRead(pirPin) == HIGH){v
 digitalWrite(ledPin, HIGH);
}

[...]


Un saludo!

#5
Jun 08, 2012, 12:41 am Last Edit: Jun 08, 2012, 12:42 am by MauricioCr Reason: 1
El pir (HC-SR501) al arduino esta así

Vcc a 5v de arduino
GND a GND de arduino
Out a 2 pin digital

Y la V perdida es error al pegar y copiar  :~

La placa es Arduino Uno R3

Gracias por su interes!

josemanu

Puede parecer una pregunta obvia pero ¿como has conectado la bateria de 9v a Arduino?
http://www.ardumania.es/

Iniciación


Heke

Pues esto es simple a mas no poder...

Si la pila esta bien y tenemos en cuenta que una pila de 9v sana puede suministrar 175mA/h, salvo que el PIR consuma "un huevo" no hay mas...

Pones polimetro y listo, si tienes 9v en ese conector respetando que el positivo sea el pin interior y masa o gnd el exterior el cacharro debe funcionar.

Que no... pues solo puede ser una gambada en las conexiones o regulador escoñado.

Tambien puedes poner el polimetro para medir consumo y sal de dudas.

Si el problema es el alto consumo del PIR (que no debe) simplemente carga el sketch de Blink en el arduino y alimentalo con la pila que por si solo (sin el PIR) con una simple pila de 9v debe funcionar y veras parpadear el led 13.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

Gracias Heke, voy a probar.

Ya tenia listo todo y cuando conecto la batería de 9V me boto el proyecto  =( =(

A ver como lo soluciono...

Go Up