Go Down

Topic: Problème de compatibilité entre ethernet shield et LCD avec pad ? (Read 1 time) previous topic - next topic

jplaville

Bonjour à tous.

J'ai un problème.

Quand je j'empile Arduino Mega ADK 2560 avec Ethernet shield, j'arrive sans problèmes à envoyer des infos via http.
Le module ethernet fonctionne nickel.
Le ping répond.

Quand je met en plus par dessus cet affichage LCD 2 lignes avec pad :




J'arrive plus du tout à avoir une connexion avec la carte ethernet.
Même le ping ne revois rien.

J'imagine que c'est parce que le LCD utilise un ou plusieurs port identique à ceux que le ethernet shield utilise !?

Si oui, je peux faire comment pour empiler un ethernet et un lcd ? 

OLIVIERC67


Bonjour à tous.

J'ai un problème.

Quand je j'empile Arduino Mega ADK 2560 avec Ethernet shield, j'arrive sans problèmes à envoyer des infos via http.
Le module ethernet fonctionne nickel.
Le ping répond.

...

J'imagine que c'est parce que le LCD utilise un ou plusieurs port identique à ceux que le ethernet shield utilise !?

Si oui, je peux faire comment pour empiler un ethernet et un lcd ? 


Si les 2 utilisent les même pins, il faut déterminer lesquelles pour commencer.
S'il y a 1 ou 2 pins, voir pour plier les pattes pour décaller les pins ou couper celle qui gène, et cabler avec du fil electrique (genre 9/10e).
Si c'est beaucoup plus, passer par une carte prepercé à bandes : http://www.sonelec-musique.com/photos/electronique_ci_vero_001d.jpg






- 1 mega 2560
- 1 Raspeberry Pi (en pré-commande)
- Quarante douze PC
- beaucoup de volonté, pas beaucoup de temps.
- Ma religion : OpenSour

infobarquee

bonjour,
oui il y a des pins communes, donc problèmes.
j'ai plus les 2 en cause en tête, regarde dans le .cpp
pour le lcd et boutons
Code: [Select]
int DB[] = {4, 5, 6, 7};  //wire these to DB4~7 on LCD.
plus la 8 et 12 et 13
pour les boutons A0

skywodd

Bonjour,


J'imagine que c'est parce que le LCD utilise un ou plusieurs port identique à ceux que le ethernet shield utilise !?

Effectivement l'ethernet shield et la lcd shield ont des pin en commun, et même beaucoup !
http://skyduino.wordpress.com/2012/05/05/test-shield-lcd-keypad-de-dfrobot/

La lcd shield utilise :
D4 D5 D6 D7 D8 D9 D10 + A0
http://shieldlist.org/dfrobot/lcd

L'ethernet shield utilise :
D4 D10 D11 D12 D13 + A0 A1
http://shieldlist.org/arduino/ethernet-v5

Il y a donc conflit entre D4, D10 et A0 !


Si oui, je peux faire comment pour empiler un ethernet et un lcd ? 

Une solution serait de couper les pistes en question sur la lcd shield et de les déplacer vers des broches inutilisé ...
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

infobarquee

exact, j'avais regardé sur un autre model que j'ai sur le bureau.  :smiley-red:

jplaville


...
Une solution serait de couper les pistes en question sur la lcd shield et de les déplacer vers des broches inutilisé ...

Ok, merci.
Mais cela ne suffit pas, il faut que je change la déclaration des pins en question dans la librairie incluse pour que cela joue, non ?

skywodd


Mais cela ne suffit pas, il faut que je change la déclaration des pins en question dans la librairie incluse pour que cela joue, non ?

Oui il faudra modifier la déclaration du brochage du lcd, mais si tu utilise la librairie LiquidCrystal c'est juste une ligne a modifier dans ton programme (et non dans la librairie).
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

jplaville


Oui il faudra modifier la déclaration du brochage du lcd, mais si tu utilise la librairie LiquidCrystal c'est juste une ligne a modifier dans ton programme (et non dans la librairie).

Merci.

En fait j'utilise la librairie spécial pour ce genre d'affichage (fourni par le vendeur) :
http://www.r3cube.com/Drivers-software/LCD4Bit_mod.zip
LCD4Bit_mod

Ca doit être presque pareil.
Dans mon code je ne déclare pas le brochage du LCD et dans la bibliothèque j'ai juste trouvé les broches 4,5,6,7,8,9,11
Mais pas de 10.

skywodd


En fait j'utilise la librairie spécial pour ce genre d'affichage (fourni par le vendeur) :
http://www.r3cube.com/Drivers-software/LCD4Bit_mod.zip
LCD4Bit_mod
Ca doit être presque pareil.

Oula ... LCD4Bit_mod ... C'est super vieux comme librairie !
Je te conseil d'aller voir les tutoriels de LiquidCrystal (http://arduino.cc/en/Reference/LiquidCrystal) et de passer à quelque chose de plus récent ;)
Surtout que LCD4Bit_mod est vraiment dépassé avec les derniers ajout fait dans LiquidCrystal (-> librairie officielle -> fourni de base avec l'ide)


Dans mon code je ne déclare pas le brochage du LCD et dans la bibliothèque j'ai juste trouvé les broches 4,5,6,7,8,9,11
Mais pas de 10.

D10 c'est pour le rétro éclairage, c'est normal que la librairie n'en tienne pas compte, mais la broche est quand même utilisé.
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

OLIVIERC67



En fait j'utilise la librairie spécial pour ce genre d'affichage (fourni par le vendeur) :
http://www.r3cube.com/Drivers-software/LCD4Bit_mod.zip
LCD4Bit_mod
Ca doit être presque pareil.

Oula ... LCD4Bit_mod ... C'est super vieux comme librairie !
Je te conseil d'aller voir les tutoriels de LiquidCrystal (http://arduino.cc/en/Reference/LiquidCrystal) et de passer à quelque chose de plus récent ;)
Surtout que LCD4Bit_mod est vraiment dépassé avec les derniers ajout fait dans LiquidCrystal (-> librairie officielle -> fourni de base avec l'ide)


Dans mon code je ne déclare pas le brochage du LCD et dans la bibliothèque j'ai juste trouvé les broches 4,5,6,7,8,9,11
Mais pas de 10.

D10 c'est pour le rétro éclairage, c'est normal que la librairie n'en tienne pas compte, mais la broche est quand même utilisé.


Au passage, il y a un logiciel pour faire ce genre de schéma, ou bien c'est bêtement du paint ?
http://arduino.cc/en/uploads/Tutorial/LCD_bb.png



- 1 mega 2560
- 1 Raspeberry Pi (en pré-commande)
- Quarante douze PC
- beaucoup de volonté, pas beaucoup de temps.
- Ma religion : OpenSour

SesechXP

Julien - www.idreammicro.com

Go Up