Go Down

Topic: GPS problems- can't get a fix... (Read 845 times) previous topic - next topic

TobyB

Jun 09, 2012, 09:11 am Last Edit: Jun 09, 2012, 09:16 am by TobyB Reason: 1
so after a bit of rewiring and poking around, I've gotten the Globalsat 406a (http://www.usglobalsat.com/store/download/46/em406a_ug.pdf)
to talk to the Mega 2650 through an Adafruit shield http://www.adafruit.com/products/98.

It'll read properly parsed empty phrases from the module indoors, and if I take it outside, it gets a bit more data.

But the problem is, it can see 12 satellites, but can't get a fix.  Tried it at work, tried it at home, same results.
I let it chug along for at least 5 minutes, no luck.  Sees 12, no fix.  Moving it, sometimes it even loses the $GPGSV phrase.
If it was a radio, I'd change the antenna, but this one's part of the module.

Using the Adafruit code modified to read through the hardware serial port 1, I get:

Read:
$GPGGA,064518.403,,,,,0,00,,,M,0.0,M,,0000*5F
Read:
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
Read:
$GPGSV,3,1,12,21,52,183,23,29,52,062,30,30,51,303,26,31,44,226,*7B
Read:
$GPGSV,3,2,12,25,33,127,,16,18,304,,05,16,051,,06,13,264,*73
Read:
$GPGSV,3,3,12,18,02,153,,23,02,313,,13,01,342,,03,-1,265,*6C
Read:
$GPRMC,064518.403,V,,,,,,,090612,,,N*48
   Time: 6:45:18
   Date: 6/9/12
   Lat: 0* 0' 0.0"
   Long: 0* 0' 0.0"

but even a simple serial1 to serial0 repeater gives the same results.


I'm GPS- clueless.  Is there something obvious I could be missing?

Thanks,

t

johnwasser

On some GPS modules it can take a long time to download the ephemeris details for each satellite.  Try leaving the module running with a clear view of the sky for a while... Possibly hours.

If that fails you might need to force a cold start to clear whatever the module thanks it knows about orbits.
Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

TobyB

Thanks, John- I'll give that a shot. 

t

RaMansell

I was just curious if things ever panned out for getting a quicker fix with your GPS.  I've started working with a Maestro A2035-H (http://www.mouser.com/ProductDetail/Maestro-Wireless-Solutions/A2035-H-V412/?qs=sGAEpiMZZMvHnN%252b%2fGH9WnSIFmGmrzLuu2xchwU9fmI4%3d) and it is acting similarly.  After about 7 minutes it figures out the right time and date (starts off with a date from 2010).  It finally gets a fix after about 30 minutes.  Until then it just shows that it can find 12 satellites!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy