Go Down

Topic: multiple ds18b20 sensors = not working (Read 744 times) previous topic - next topic

woodc

I am hoping someone can assist me with an odd ds18b20 issue  :smiley-mr-green:

I have 3 ds18b20 sensors that I bench tested by manually wiring them all 3 to power then the signal pin of each went to a breadboard that had a 4.7k resistor between them and a pin on my arduino.  It worked great, all 3 sensors registered temps at the same time.

After that I wired two of the sensors up on the end of the same cable (sharing power/ground/signal) and connected it and confirmed it worked as expected (two temps shown).  When that was done I wired up the final sensor and confirmed it also worked as expected.

Unfortunately what is *not* working is having both cables (all 3 sensors) connected at the same time.  Either one works by itself but as soon as I plug the second signal connection in the arduino acts like it cannot see any sensors.

FWIW I am using the onewire example code and an arduino mega connected to pin 53.

Any ideas?

Jack Christensen

The 4.7K resistor does not go "between" the DS18B20s and the Arduino pin, it's a pullup resistor from the data pin to Vcc. Any chance of posting a schematic?
MCP79411/12 RTC ... "One Million Ohms" ATtiny kit ... available at http://www.tindie.com/stores/JChristensen/

woodc

Dropped down to a 1k resistor and it is working now  :)

woodc

This is the wiring schematic I used:  http://bildr.org/2011/07/ds18b20-arduino/

Cheers

Go Up