Go Down

Topic: Leonardo mouse and keyboard issues (Read 616 times) previous topic - next topic

GTech13

I just got my Leonardo and was excited to try the mouse and keyboard features.  I have had much trouble with both.  The keyboard seems to only somewhat work.  Sometimes a very press and release of a single key (with a delay) with notepad open doesn't work.  Also the logout example doesn't work.  Ctrl+Alt+Del doesn't seem to work.  I can't really explain exactly what issue I'm having with keyboard other than mostly not working.  I'm running windows vista BTW.

How is the mouse.move suppose to work?  What number do I put for the ints?  I thought it was maybe the number of pixels but that is clearly not the case.  I tried to move -1440, -900 to corner the mouse then move 720, 450 to center it from wherever it was but that just makes it jump around a bit.

Any ideas appreciated, Thanks!

Justblair

I just tried the logout example with Windows and it worked fine for me on my DaVinci (Leo-clone)

Just to rule out the obvious, did you change this line...
Code: [Select]
// change this to match your platform:
int platform = OSX;

to WINDOWS?

mellis

The arguments to Mouse.move() are relative (i.e. changes to the current mouse cursor position).  Can you post the full code for the keyboard programs you're having trouble with?

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy