Go Down

Topic: Arduino 2560 Stuck on Uploading Sketch (Read 8524 times) previous topic - next topic

cyclegadget

Quote
Okay, if DTR is messed up, does it mean that the chip handling serial is broken??
And will bypassing it with FTDI cable do the trick?????


If you already have a cable, it won't hurt to try. If you had a Uno with a removable chip, you can hook tx-tx, rx-rx, reset-reset, 5v-5v, gnd-gnd together and that will work.
Good links: Eagle tutorial= http://www.youtube.com/playlist?list=PLDE1858BD83D19C70
General Arduion tutorials = http://tronixstuff.wordpress.com
http://www.gammon.com.au/forum/bbshowpost.php?bbtopic_id=123

xvjeko


Quote
Okay, if DTR is messed up, does it mean that the chip handling serial is broken??
And will bypassing it with FTDI cable do the trick?????


If you already have a cable, it won't hurt to try. If you had a Uno with a removable chip, you can hook tx-tx, rx-rx, reset-reset, 5v-5v, gnd-gnd together and that will work.



unfortunately, i don't have it  XD
but some people did it
http://arduino.cc/forum/index.php?topic=105243.0

hpt007

It works! XD
I changed the USB cable AND I use an external power supply during upload now. The power LED is  on even w/o external power supply, but the upload won't work. After the upload I can remove the external power and the board still works.

cyclegadget

Good links: Eagle tutorial= http://www.youtube.com/playlist?list=PLDE1858BD83D19C70
General Arduion tutorials = http://tronixstuff.wordpress.com
http://www.gammon.com.au/forum/bbshowpost.php?bbtopic_id=123

Calamari

I had a similar problem...

My fix was to plug my USB cable DIRECTLY into my motherboard USB port bypassing USB hubs / monitor hubs etc.

Worked flawlessly after that...

Go Up