Go Down

Topic: Communication Problems - stk500_getsync(): not in sync: resp=0x00 (Read 1 time) previous topic - next topic

dayta_eng

Jun 12, 2012, 04:27 pm Last Edit: Jun 12, 2012, 05:07 pm by dayta_eng Reason: 1
I very recently purchased a new Arduino UNO starter kit.
I am having problems with getting the installation correct and communicating with the board, although I believe I have installed everything correctly according to the instructions but perhaps someone can point out where I have gone wrong:

So I plugged in the board and Windows tried to install a driver and failed (as the instructions say).
In device manager I pointed the "Unknown Device" to the correct driver in the Drivers file in arduino1.0.1.
The Driver installed successfully and the device was then listed under Ports (COM & LPT) with the name "Arduino UNO R3 (COM3)" (I verified that it was indeed COM3 in the properties.

I then opened the Arduino IDE and checked the settings for the device:
Tools - Board - Arduino UNO,
Tools - Serial Port - COM3 (selected with a tick by it)

I then opened the blink example and tried to upload the code. Sure enough it compiles but it returns the following error:
avrdude: stk500_getsync(): not in sync: resp=0x00
If I hold shift during the upload I get the following message:
avrdude: usbdev_open(): did not find any USB device "usb"

When trying to upload the Rx LED blinks 3 times but the Tx LED does not blink.

I have looked at the error online but so far none of the solutions I have seen have solved the problem for me. Here is some further information on what I have tried:

Loop-Back Test : nothing was returned from this using the serial monitor.
Disabled firewall.
Tried different USB ports.
Uninstalled and reinstalled drivers.

Help would be much appreciated as I would really like to start programming soon.

I am using Windows 7 32bit OS.

Thanks

James C4S

Quote
Loop-Back Test : nothing was returned from this using the serial monitor.

Until this works, nothing else is going to work.

If you remove the Arduino, does COM3 disappear from the system?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Nick Gammon

Which Uno came in the starter kit? Try downloading an earlier version of the IDE.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

mellis

In Arduino 1.0 and later, you can get verbose output by checking a box in the preferences dialog (holding "shift" uploads via an external programmer, which is why it gives you a different error).  Can you post the output from that?

Do you have any bluetooth scanning / communication programs running (maybe in the background) or software for a cellular internet dongle or anything else that might be grabbing USB ports?

patrickeidemiller

#4
Jun 15, 2012, 04:53 am Last Edit: Jun 15, 2012, 04:55 am by patrickeidemiller Reason: 1
I'm having the same problem.  I had successfully connected and programmed the unit, and now No Joy.
Uno R3, windows Vista 64-bit, Arduino IDE 1.0.1

Tested different com ports, tested different USB cable, tested different USB ports, tested on Win 7 machine.

Power led is green, and digitial 13 led is yellow.

Com ports in agreement between windows device manager and Arduino IDE
Loop back test successfully echo's the input.
==========================
Verbose out from monitor:
Binary sketch size: 1,084 bytes (of a 32,256 byte maximum)
C:\Users\Patrick Eidemiller\Projects\V3\SupplySolutions\Arduino\arduino-1_0_1\hardware/tools/avr/bin/avrdude -CC:\Users\Patrick Eidemiller\Projects\V3\SupplySolutions\Arduino\arduino-1_0_1\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P\\.\COM6 -b115200 -D -Uflash:w:C:\Users\PATRIC~1\AppData\Local\Temp\build8167292190882310592.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Users\Patrick Eidemiller\Projects\V3\SupplySolutions\Arduino\arduino-1_0_1\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM6
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

Go Up