Pages: [1]   Go Down
Author Topic: Arduino 1.0.1, Leonardo in boards.txt but not in IDE boards list  (Read 816 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Apologies in advance if I've done something stupid.

Just received a shiny new Leonardo from la casa de Sparkfun.  I promptly downloaded the 1.0.1 IDE from here. I installed the driver according to this.

I opened up the IDE and set the port.  I went to change the board but Leonardo was not on the list.

I poked the google machine a couple of times only finding this problem occurring in 1.0 and solved by uncommenting the boards.txt file.  I opened the boards.txt file for the 1.0.1 IDE and found Leonardo there not commented out. 

Has anyone else seen this?  Or, did I do it wrong?

Thanks


* LeonardoMissing.JPG (78.73 KB, 748x624 - viewed 21 times.)

* ideBoardList.JPG (68.52 KB, 792x483 - viewed 22 times.)

* devmgmt.JPG (10.58 KB, 278x40 - viewed 23 times.)
Logged

Dallas, Texas
Offline Offline
God Member
*****
Karma: 31
Posts: 887
Old, decrepit curmugeon
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you still have an older version of the Arduino software loader on that machine?  I wonder if the reason it is not showing is because it is reading a different set of configuration files from those that came with 1.0.1?
Logged

New true random number library available at: http://code.google.com/p/avr-hardware-random-number-generation/

Current version 1.0.1

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I haven't seen this, but I wonder if it's a line-ending issue.  Maybe try deleting all the line endings and then re-inserting them? 

Also, do you have anything in the hardware sub-directory of your sketchbook?  It's possible that a boards.txt file there is somehow interfering with the one that comes with the software.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry for the late reply.

Wanderson:  I made sure to not intermix my Arduino directories. But, just for fun, I opened up boards.txt from Arduino 1.0, uncommented Leonardo and checked in the IDE...Leonardo was there as expected. 
I checked last night on my machine at the house (set up for Arduino identically to this machine) and in 1.0.1 Leonardo was there.  I downloaded 1.0.1 to each machine on the same day, within hours of each other.

Mellis: Nothing in my hardware subdir other than arduino and tools folders.  I will try your suggestion and let you know how it went.


* LeonardoPresent.JPG (75.79 KB, 684x632 - viewed 15 times.)
Logged

Europe
Offline Offline
Full Member
***
Karma: 0
Posts: 104
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Apologies in advance if I've done something stupid.

Just received a shiny new Leonardo from la casa de Sparkfun.  I promptly downloaded the 1.0.1 IDE from here. I installed the driver according to this.

I opened up the IDE and set the port.  I went to change the board but Leonardo was not on the list.

I poked the google machine a couple of times only finding this problem occurring in 1.0 and solved by uncommenting the boards.txt file.  I opened the boards.txt file for the 1.0.1 IDE and found Leonardo there not commented out. 

Has anyone else seen this?  Or, did I do it wrong?

Thanks

aviod unlicenced manufacturers such as sparkfun, you wont get support...
Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think you have been misinformed, Sparkfun has always been an authorized distributor of Arduino products.
See the distributors page under USA, they are the first one listed:
http://arduino.cc/en/Main/Buy
Logged

Pages: [1]   Go Up
Jump to: