Pages: [1]   Go Down
Author Topic: Ethernet Shield SD Card Pins (Mega) ?  (Read 2655 times)
0 Members and 1 Guest are viewing this topic.
Spain
Offline Offline
Jr. Member
**
Karma: 0
Posts: 51
I hope I'm not too old for this stuff...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Sorry if this has been asked before.
I have an Ethernet Shield purchased on eBay supposedly Mega compatible.
I am trying to access the SD card to noavail.
The Shield details are:
HanRun HR911105A 10/49 mounted on an Arduino Mega 2560
I tried the standard ReadCardInfo sketch.
Default setting. Generates standard "Is card initialized etc"
Changed pins according to sketch, but still same errors.
Reformatted card to FAT32 still same.
Am using 2GB card.

As these shields are selling like hot cakes on eBay I am hoping someone has the correct pins worked out?
If so any help would be appreciated?

Thanks and kind regards,

jB  smiley-cool
Logged

=====================================================
My Grandkids think I'm cool but, actually I'm partially sighted so sorry for any typos

Miramar Beach, Florida
Online Online
Faraday Member
**
Karma: 150
Posts: 6141
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Post a link to the eBay site page where they are "selling like hot cakes". There are a few types of ethernet shields, and each are different.
Logged

0
Offline Offline
Edison Member
*
Karma: 67
Posts: 1658
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This is not a formatting problem.  It is a basic I/O problem.

Don't format cards 2GB or less as FAT32.  The SD standard requires small cards to be FAT16. Use this formatter to get the correct standard format https://www.sdcard.org/downloads/formatter_3/.

Once again you must solve the basic I/O problem before formatting will help.
Logged

Spain
Offline Offline
Jr. Member
**
Karma: 0
Posts: 51
I hope I'm not too old for this stuff...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Here is an example of what I have got.
Code:
http://www.ebay.co.uk/itm/Ethernet-Shield-W5100-For-Arduino-2009-UNO-Mega-1280-2560-/300695278167?pt=UK_Sound_Vision_Other&hash=item4602d5d257

Thanks

jB  smiley-cool
Logged

=====================================================
My Grandkids think I'm cool but, actually I'm partially sighted so sorry for any typos

Miramar Beach, Florida
Online Online
Faraday Member
**
Karma: 150
Posts: 6141
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

When you upload the CardInfo sketch, you get this on the serial monitor?
Quote
Initializing SD card...initialization failed. Things to check:
* is a card is inserted?
* Is your wiring correct?
* did you change the chipSelect pin to match your shield or module?

Then in the CardInfo code:
Code:
  // after this in setup()
  pinMode(10, OUTPUT);     // don't change this to 53 on a mega
  // add this
  digitalWrite(10,HIGH);

After that change, I get:
Quote
Initializing SD card...Wiring is correct and a card is present.

Card type: SDHC

Volume type is FAT32

Volume size (bytes): 4115660800
Volume size (Kbytes): 4019200
Volume size (Mbytes): 3925

Files found on the card (name, date and size in bytes):
TEST.TXT      2000-01-01 01:00:00 20
TESTFILE.TXT  2000-01-01 01:00:00 29
Logged

Spain
Offline Offline
Jr. Member
**
Karma: 0
Posts: 51
I hope I'm not too old for this stuff...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you very much...
Kind regards,
jB
Logged

=====================================================
My Grandkids think I'm cool but, actually I'm partially sighted so sorry for any typos

Pages: [1]   Go Up
Jump to: