Go Down

Topic: bloccato??? ... non carica più nulla!!!!! (Read 979 times) previous topic - next topic

Paolo S

... ho cercato con la funzione di ricerca ma non ho trovato nulla riguardo a questo problema:
- dopo aver settato come OUTPUT i pin 0 e 1, destinati alla comunicazione seriale (rx e tx), ed averne messo i valori su "alto" durante il funzionamento dello sketc,... ora mi sono accorto che non riesco a uploadare niente.

Per adesso ho risolto sostituendo il micro con un altro che avevo di riserva....

ma come faccio a sbloccare il primo micro??? ..
durante i tentativi di upload non mi dava nessun errore, semplicemente non c'èra il classico lampeggio rx e tx e non caricava nulla ....
forse dovrei provare il metodo con il reset cercando la giusta sincronia tra il rilascio del tastino reset e l'attivazione dell'upload ....


suggerimenti???




 

Michele Menniti


... ho cercato con la funzione di ricerca ma non ho trovato nulla riguardo a questo problema:
- dopo aver settato come OUTPUT i pin 0 e 1, destinati alla comunicazione seriale (rx e tx), ed averne messo i valori su "alto" durante il funzionamento dello sketc,... ora mi sono accorto che non riesco a uploadare niente.

Per adesso ho risolto sostituendo il micro con un altro che avevo di riserva....

ma come faccio a sbloccare il primo micro??? ..
durante i tentativi di upload non mi dava nessun errore, semplicemente non c'èra il classico lampeggio rx e tx e non caricava nulla ....
forse dovrei provare il metodo con il reset cercando la giusta sincronia tra il rilascio del tastino reset e l'attivazione dell'upload ....
suggerimenti???

Hai bloccato la seriale, il metodo di fare upload usando manualmente il tastino di reset è quello giusto per sbloccare il micro.
In alternativa, visto che hai la possibilità, puoi semplicemente ricaricare il bootloader mediante la tecnica ISP
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

uwefed

Togli tutto quello che é collegato ao pin 0 e 1.
Ciao Uwe

Paolo S


Paolo S

non c'è verso!!!
.. con il reset non cè verso.

devo cercare altre soluzioni ......
Prof. Menniti ... mi sembra lei abbia studiato approfonditamente il problema ....  che suggerimento mi dà?


PaoloP


In alternativa, visto che hai la possibilità, puoi semplicemente ricaricare il bootloader mediante la tecnica ISP

Se ne hai la possibilità, usa un secondo Arduino come programmatore ISP. Dovresti risolvere.
Code fast. Code easy. Codebender --> http://codebender.cc/?referrer=PaoloP

Paolo S

non l'ho mai fatto. Stasera proverò...
grazie

flz47655

Se tutto quello consigliato non funziona l'ultima spiaggia è sempre un reset ad alta tensione, dopo bisogna risettare i fuse e ricaricare il bootloader

Ciao

Go Up