Pages: [1]   Go Down
Author Topic: Lichtsensoren und Taster funktionieren nicht?  (Read 601 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo zusammen

Voller Freude ist endlich der Tinker Mega Sensor Shield in meinen Händen - leider aber scheinen die Taster und Lichtsensoren nicht zu funktionieren? Beim Schalter sehe ich hinten zwar die zweite LED leuchten, wenn ich den Schalter drücke - allerdings liefert die Überprüfung mittels .on() kein true... Der Lichtsensor liefert permanent etwas um den Wert 777... Ich habe auch schon die Kabel gewechselt und verschiedene Steckplätze probiert, allerdings ohne Erfolg.

Teile:
Arduino Mega Rev3
TinkerKit Mega Sensor Shield V.2
TinkerKit LDR Sensor
TinkerKit PushButton
TinkerKit Thermistor Module

Arduino IDE: 1.0.1

Was mich auch ein wenig irritiert hat, sind die fehlerhaften Codebeispiele... Aber das ist für mich das kleinere Übel.

Habe ich irgend einen grundlegenden Fehler gemacht? Bei der Verkabelung kann man ja nicht viel falsch machen: Sensoren gehören an die Inputs, LEDs an die Outputs.

Über Ratschläge und Troubleshootings würde ich mich freuen.

Liebe Grüsse
TinkTank


EDIT:
Inzwischen klappt alles, ist mir unklar wieso. Aber irgendwas werd' ich wohl falsch gemacht haben beim letzten Mal smiley

@mkl0815: Danke für den Ratschlag, das werde ich in Zukunft beherzigen!
« Last Edit: June 18, 2012, 03:53:46 pm by TinkTank » Logged

Offline Offline
Edison Member
*
Karma: 21
Posts: 1419
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo TinkTank,

willkommen im Forum. Bei Posts mit konkreten Fragen ist es für die mitlesenden hilfreich, wenn Du Links zu den von Dir verwendeten Komponenten postest, denn mittlerweile gibt es so viele Erweiterungen und Shields, das wir nicht alle kennen können.
Weiterhin ist es gut zu Deinem Problem zusätzlich zu schreiben, welche Version der IDE Du verwendest. Hier gab es in jüngerer Zeit einen größeren Versionswechsel, der dazu führt, das viele ältere Beispiele und Bibliotheken Probleme bereiten. In solchen Fällen sind die Fehlermeldungen des Compilers / der IDE hilfreich, da man so das Problem schnell eingrenzen kann.

Da Du vermutlich den Code angepasst hast, damit die IDE ihn übersetzt, wäre es gut, wenn Du den Code auch postest. Am besten in den "#" Code-Tags, das macht das Lesen einfacher.

Mario.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo mkl0815

Danke für's Willkommenheissen und für den Ratschlag. Glücklicherweise konnte ich den Fehler bei mir verorten. Den Taster habe ich erst fälschlicherweise mit .pressed() anstelle von .get() auf sein Gedrücktsein geprüft. Beim Lichtsensor weiss ich nicht, was ich falsch gemacht habe.

Code:
#include <TinkerKit.h>

// input
TKLightSensor ldr(I1);
TKButton button(I2);
TKThermistor thermistor(I5);

// output
TKLed led(O0);

// values
float valTemperature;
int valBrightness;
boolean valPressed;

void setup()
{
  Serial.begin(9600);
}

void loop()
{
  valTemperature = thermistor.getCelsius();
  valBrightness = ldr.get();
  valPressed = button.get();

  if(valTemperature > 30)
  {
    led.on();
  }
  else
  {
    led.off();
  }

  Serial.print("\tvalTemperature: \t");
  Serial.print(valTemperature);
  Serial.print("\tvalBrightness: \t");
  Serial.print(valBrightness);
  Serial.print("\tvalPressed: \t");
  Serial.print(valPressed);
  Serial.println();

  delay(1000);
}

Liebe Grüsse
TinkTank
Logged

Pages: [1]   Go Up
Jump to: