Go Down

Topic: Problemi Arduino Leonardo (Read 2161 times) previous topic - next topic

Frodo478

Ho acquistato da poco un Arduino Leonardo ma stò avendo alcuni problemi con un particolare sketch...
Quando la collego al pc  sembra (non sempre) che il sistema la riconosca, sia sotto windows che sotto linux, ma quando vado a caricarci sopra lo sketch, l'IDE di Arduino segnala Uploading... ma non finisce più e a volte si blocca completamente e non è possibile fare più ninete finchè non resetto la scheda.
A volte la scheda si scollega da sola cambiando porta e con questo sketch proprio non ne vuole sapere...
Code: [Select]

#include <IRremote.h>

const int RECV_PIN = 6;
IRrecv irrecv(RECV_PIN);
decode_results results;

void setup() {
  Serial.begin(9600);
  irrecv.enableIRIn();
}

void loop() {
  if (irrecv.decode(&results))
  {
    if (results.decode_type == NEC)
    {
      Serial.print("NEC: ");
    }
    else if (results.decode_type == SONY)
    {
      Serial.print("SONY: ");
    }
    else if (results.decode_type == RC5)
    {
      Serial.print("RC5: ");
    }
    else if (results.decode_type == RC6)
    {
      Serial.print("RC6: ");
    }
    else if (results.decode_type == UNKNOWN)
    {
      Serial.print("UNKNOWN: ");
    }
    Serial.println(results.value, HEX);
    irrecv.resume();
  }
}

Cosa c'è che non piace alla leonardo nello sketch??  =(
grazie   :D

leo72

La scheda è molto nuova, forse sei anche uno dei primi ad averla acquistata. Io personalmente non so risponderti, non avendola né sapendo come funziona.  :smiley-sweat:
Ma questo comportamento te lo fa sia sotto Window che sotto Linux? Cioè il cambiare porta da sé?

lesto

azz, già le prime leonardo in giro? sicuro sia originale? (tranquillo, nessuno ti spara, ti diciamo che te la sei cercata di certo, però è per vederci chiaro senò è inutile)

comunque ad occhio si tratta più di un problema di comunicazione USB del firmware sulla scheda, magari per una rara incompatibilità?? riusciresti a provare su di un altro PC?
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

Frodo478

sisi originale, lo comprata da pochissimo e la stò testando in questi giorni...
il problema me lo fà sia sotto linux che sotto windows e solo con questo sketch...
la comunicazione seriale lo già testata con altri sketch è mi sembra abbastanza lineare..

uwefed

Ho comprata una domenica ma non ho l'ancora provata.
So dirti qualcosa prossimamente.
Ciao Uwe

Federico Vanzati

controllerò se c'è qualce incompatibilità
F

lesto

allora da linux scollega la board e lancia l'ide
collega la board, uppa il codice, ripeti finchè non beccho il problema, poi fai

dmesg > file.txt

prendi codesto file.txt e lo alleghi quì (se non ci sta zippalo o simili)
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

leo72

Tu dici che ti salta la seriale, nel tuo sketch stai usando la seriale oltre ad un'altra libreria. Prova creando 2 sketch singoli, uno con la seriale e l'altro con l'altra libreria.

lesto

i lol'd, è lo stesso problema che ho io usando la seriale con un alto baudrate, amplificato

Quote
Using the serial monitor effectively: Since serial is going through only one processor on the Leonardo, the board is capable of filling your computer's serial buffer faster than the Uno or earlier boards. You may notice that if you send serial continually, for example like this:

void loop() {
    int sensorReading = analogRead(A0);
    Serial.println(sensorReading);
}
[Get Code]

the Serial Monitor in the IDE slows down considerably as it tries to keep up. If you encounter this, add a short delay to your loop so that the computer's serial buffer is not filled as fast. Even a millisecond delay will help:

void loop() {
    int sensorReading = analogRead(A0);
    Serial.println(sensorReading);
    delay(1);
}
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

Frodo478

ok
la seriale lo già usata e funge
ho provato la libreria singolarmente salvandomi la variabile letta dal ricevitore ir e mi carica lo sketch senza problemi
credo che il problema sia proprio nella libreria utilizzando la comunicaione seriale...
però lo stesso sketch testato su arduino uno funziona...

leo72


credo che il problema sia proprio nella libreria utilizzando la comunicaione seriale...
però lo stesso sketch testato su arduino uno funziona...

Ma la UNO è differente. Andrebbe capito cosa c'è che non va usando entrambe le librerie.

pablos

Scusate cosa ha la leonardo più di un altro 328? ci sono sempre quei miserabili 16Km/h di clock  XD XD XD
no comment

leo72

La Leonardo ha un unico chip, l'Atmega32U4, che integra un convertitore seriale/USB per cui non necessita del chip accessorio delle UNO e delle MEGA. Avendo quindi la gestione USB in hardware può in teoria essere programmata per emulare una periferica USB.

pablos

Grazie Leo :) ... ahhh bhe mi consolo allora. Non c'e' speranza di ottenere un mcu più veloce. =( l'importante è integrare
no comment

superlol


Grazie Leo :) ... ahhh bhe mi consolo allora. Non c'e' speranza di ottenere un mcu più veloce. =( l'importante è integrare

puoi portarla da solo a 20MHz, basta che cambi il quarzo e sul forum italiano se ne è parlato molto, astro se non sbaglio aveva rilasciato un firmware buono a riguardo, o forse era menniti? troppe guide di troppi utenti  XD

comunque io sto aspettando la due da un anno giusto..

mi sa che è una leggenda come il mostro di lochness  XD

comunque hai provato premendo il reset quando nell'ide ti dice le dimensioni effettive dello sketch?
se è un problema di seriale, se il firmware è fatto bene, allora dovresti risolvere
Il nuovo forum italiano sull'elettronica: http://www.electroit.tk/ <--- Nuovamente online!

Go Up