Go Down

Topic: cheap sound module: what version is this? (Read 82290 times) previous topic - next topic


#Argentina. this is my module: WTV020-SD-mini
as you click the one with bit 0 on pin 9, your module does not play?

now I have to leave, but so I'll try to get some more. I've slept and nights without anything. I stopped with 2 modules or 8 months.

thank you for your attention and help.

much peace.

Look, It seems you have a control key audio module and we a serial control mode module. Each can't perform both. It is hardwired. You should ask the vendor which mode shipped to you. Mine is serial, so I can't test it in key mode.


#wanderlg, your EnviarDatos() is wrong. Why don't you translate my library posted here:

Pretty sure I will work. And I can not test mp3 mode cause my module is only serial control mode.

used goldwave first and then the somo as linked before

Will try that. Keep you posted.


the strange thing is that my module is the same as you show in a photo and a video. have the same module. My buttons can be configured and also for serial.


I use exactly this module.


I give up. this shit does not work. that sucks. ta giving the will of a sledgehammer on top of that module.


Aug 05, 2012, 04:51 pm Last Edit: Aug 05, 2012, 04:56 pm by wanderlg Reason: 1
see the photo of the module. sorry, I do not know how to put the picture without the link.

waveform signal clk / di



Hey, don't give up. Today got a second audio module and this one really works. My first one was defective. wow, got all the possible defects and got the correct source code to make it work after all. Anyway. Already asked for a replacement for the first one. eBay vendor will honor this word and will send me another one.

From the photos I see that your audio module is older than ours. Mine is version 1.5 released this year. Yours is version 1.3? 1.4? anyway, I don't think they can be setup both ways, serial or key mode. That will explain you can not get serial mode to work.

PS: Tested all the micro sd cards again and fake Kingstone still don't work, but genuine one and two Sandisk do.


I do not understand, because the module through key ta touching the 0006.ad4 0000.ad4 files but not play through the serial. and I've tried all the examples and modifying of all forms. neither I nor the seller who is now my friend can do this work through the serial module. only remains for me to try to use the brand Sandisk 1gb microsd. I will buy this one for testing.

Ps: through key works with any brand 512MB to 4GB. I believe that your work too well. mine is version 1.4 - 2008


Hey, read my words: These modules can't work both ways. Only SOMO14d and SoundOut Audio Module can do that. Your module is working just fine. If you want to control via serial mode, you will have to buy a new one. Try the seller OneSky listed in the first post.


then this one is not useless, because a mp3player is much cheaper and more functional than the one I bought. thank you by force.


is not something that enters my head. vendors and datasheet say that the module accepts serial. and now?


friend. My module is the same and the same somo14d. what happens is that the chip has somo14d shaved, but the same WTV020 see this:


all use the same chip, the same form of serial data transmission. you're putting your files 0000.ad4 0001.ad4 ... ? you're putting in the root of the microsd? formatted with fat? you have to compress the files that you use your card and send me? my email is: wanderlg@gmail.com
thanks for the help.


I am well aware that our generic module shares the same IC than SOMO14 and that compliant one. BUT, I am pretty sure they modify it somehow to support both control modes. Will test mine right away in mp3 key mode to make sure only works in serial mode. Keep you posted. BTW, I updated the library adding new features.


You were absolutely right. Mine works in key mode and serial mode. Nevertheless, the seller assured me this was serial-control mode only. Now makes sense for me SOMO14 dual functionality. I can confirm that V 1.5 could work both ways. Not pretty sure about previous versions of this audio module. Tested play, pin 9 to ground, and next, pin 13 to ground. Both worked out just fine. Did try this mode the first time, but since my first sd card was not working, never tried it again. Thanks to you to make me back to test this mode.


I do not compriendi. with a module you were stopped, as tested and not operated in serial mode, but now he works as a key? is it? you're with a module that is working just the way key? microsd tested with another brand? My module works with any brand.

friend, you realized that I do not know any English, right? I use google translator. I'm in Brazil. to understand what the google translate this?

ps: I will not stop my tests until the module has burned or run.  :D kkkkkk. it has to work, I'll redo this module as the module soundout

you have to compress and send me the data from your memory card?

Go Up