Go Down

Topic: cheap sound module: what version is this? (Read 37 times) previous topic - next topic

the-rebel-agent

Video update about my Arduino project. Now with fire selector: Regular or Stun laser gun.

http://www.youtube.com/watch?v=IpUpi0OmHHI

transfinite


Hey guys, anyone using it at 5V? Cause I moved the soldered pin from 3.3 to 5 and could not get it to work. Quite erratically. I did not use any diode cause I believe they are soldered in the pcb board. Any idea?


the-rebel-agent, is it working on 5V now?  I've been using your Wtv020sd16p library but with 3.3V.  Did you have to change anything other than the soldered pin on the wtv020 to make it work with 5V?

Thanks,

-transfinite

transfinite

Ok, nevermind.  I see you answered my question in this post.

  http://arduino.cc/forum/index.php/topic,117009.45.html


-transfinite

the-rebel-agent

No problem. If you have anything else to ask, just do it. And as I stated to @onesky, there is no quality difference working on any voltage. And won't be any difference for the library I wrote.

Waytronic-Jasmine(Li)



Don't Arduino nano have a 3.3v output?
yes but .. "when running on external (non-USB) power, the 3.3V output (which is supplied by the FTDI chip) is not available"
http://arduino.cc/en/Main/ArduinoBoardNano

so i think i will try to change the solder to the 5volts pin as suggested by Johnwasser (thank you)


Pls don't use 5 V ,it will destory our module directly ,maybe when you use for a while.the main chip of WTV020-SD module maximum voltage is 3.6V,so work voltage can not beyond 3.6V.
waytronic(WT)--manufacturer and designer of sound module,voice chip ,recording module.WT have designed WTV,WTH.WTN3 series voice chip,WTV020

onesky


Pls don't use 5 V ,it will destory our module directly ,maybe when you use for a while.the main chip of WTV020-SD module maximum voltage is 3.6V,so work voltage can not beyond 3.6V.


then why on the board there is a pin switch 5v - 3.3v?


onesky

#171
Mar 03, 2013, 05:23 pm Last Edit: Mar 03, 2013, 06:01 pm by onesky Reason: 1

Did work. It was my fault. I forget to read the manual and connect to 5v the Shutdown pin. Works like a charm. Now, I will write a library to control the volume. Keep you posted guys.


are you sure that the Shut Down pin has to be connected to the arduino 5volts?

this is what datasheet says:
Quote
In order to reduce power consumption while not in use, the PAM8803 contains shutdown circuitry that is used to turn off the amplifier's bias

circuitry. This shutdown feature turns the amplifier off when logic low is placed on the SHDN pin. By switching the SHDN pin connected to GND,

the PAM8803 supply current draw will be minimized in idle mode. The SHDN pin cannot be left floating due to the pull-down internal.


it means, if i am not wrong, that we can shut down the ampli when not in use simply connecting the shutdown pin to a digital pin of Arduino and then set the signal to LOW.

jeremixogg

I may post in the wrong topic but anyway, I need to be sure.

This module do play .wav files (16bits, 44,1 Khz) ?

task

I am trying to get this one () to work with my Arduino
I am using the sandisk 4GB micro SD card.  The light comes and goes.  It looks like it is doing something.  I ordered a 1GB SD card.  I should probably get it in a month

In case I can get one working, what will I need to do to get 3 working at the same time so that I can play 3 sounds at the same time?  I will be using the Teensy 3 at 96Mhz so I will have alot more speed available if that is an issue.  Will I have to use 4 pins for each module?  It almost looks like I might be able to share at least the reset pin for each module so then I will have to use 3 pins per extra module.  Does that sound about right?

jeremixogg


Is this module can play .wav files (16bits, 44,1 Khz) ?

onesky

it plays AD4 files format at very low bitrate (low quality)

if you need high quality i suggest a better module like this:
http://arduino.cc/forum/index.php/topic,150535.0.html

Realow

Hey guys, I read the two topics more than one time, I am using the module WTV020-SD-mini with the jumper in 3.3V and wired to an arduino nano board, I used The (the-rebel-agent)'s code that uses the busy pin of the sound module but the mine stay lit all the time, it blinks twice when I energize the Arduino, and after I press the firing button too, but it stays lit all time and when I press the button it just goes down and lits up again.

Any idea of what should be happening with it? To keep the busy led lit all the time?

Thank you guys!

Go Up