Pages: 1 ... 6 7 [8] 9 10 ... 12   Go Down
Author Topic: cheap sound module: what version is this?  (Read 32841 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Well if you think about it, the size of the AD4 files that we are playing are only like 21kb. that is such a small fraction compared to 2.5mb per second.
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I played small ad4 files and got the same error. Even the SOMO samples files failed to play entirely. Will try to get one of those generic memories. Were you able to try that 2gb memory? IF SOMO 14d works with 2gb, and this module is sharing the same chip. Maybe could work. A coworker is lending me a 2gb card today. Will try to test it.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I read somewhere the the modules would only support up to a 1GB card
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I know, but worth the try. Last night I tried my new Sandisk. Same weird behavior. I took the wavs from Windows OS, small ones, and ad4 files only were 2kb long. Converted 16 tracks, some of them played great, other same defect. Only for a few seconds. It is not about the size, there is something wrong with the micro sd card brand, model or the audio module is defective. I requested a new one from eBay vendor.
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Posted the library here:
http://arduino.cc/forum/index.php/topic,117009.new.html#new
Logged

Italy
Offline Offline
Full Member
***
Karma: 3
Posts: 151
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I know, but worth the try. Last night I tried my new Sandisk. Same weird behavior. I took the wavs from Windows OS, small ones, and ad4 files only were 2kb long. Converted 16 tracks, some of them played great, other same defect. Only for a few seconds. It is not about the size, there is something wrong with the micro sd card brand, model or the audio module is defective. I requested a new one from eBay vendor.
  i had same beahaviour, i solved  first encoding the wave into 32khz then converting to AD4
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Texo original em portugues.

A Paz meus amigos.

Amigos, eu necessito muito da ajuda de vocês. Comprei 2 modulos WTV020-SD-Mini. Já tem 8 meses que venho tentando fazer esse modulo funcionar e perdi a esperança.
Vi que vocês conseguiram, teria como algum de vocês fazerem um teste para eu saber se meu problema é realmente o cartão de memória. Veja: ele esta tocando se eu apertar play. (Colocando 0 no pino 9) ou seja por botões ele funciona, mas pelo microcontrolador não consigo. Tem como você testar com o microsd Kingston e verificar se ele toca apertando play? (colocando 0 no pino 9) aqui toca e posso mudar de ad4. coloquei 6 arquivos. 0000.ad4 a 0006.ad4 esse é meu código:

-------------------------------------------------------------------------------
text translated by google

Peace my friends.

Friends, I really need your help. I bought two modules WTV020-SD-Mini. Already have eight months I have been trying to make this module work and lost hope.
I saw what you did, would any of you do a test so I know if my problem is really the memory card. You see, he is playing if I hit play. (Put 0 on pin 9) or by buttons it works, but can not by the microcontroller. Its you test with Kingston MicroSD and see if he plays pressing play? (putting 0 on pin 9) plays here and I can change ad4. I put six files. 0000.ad4 the 0006.ad4 this is my code:


Device = 16F628A
Xtal=4
Config CP_OFF, WDT_Off, PWRTE_ON, LVP_OFF, MCLRE_On, BODEN_off, xt_osc
All_Digital=true

Symbol Reset = PORTA.0
Symbol CLK = PORTA.1
Symbol DI = PORTA.2

Dim Dados As Word
Dim X As Byte
Dim T As Word

'Iniciando Modulo
Input Reset
Input CLK
Low DI
DelayMS 100

Inicio:

Dados = 3 'play 0003.ad4
GoSub Resete
GoSub EnviaDados

Stop

GoTo Inicio

;---------------------------------------------------------------------------
EnviaDados:
 Low CLK
DelayMS 2
  For X = 15 To 0 Step -1 
    Low CLK                 
    If GetBit Dados,X = 1 Then         
      Input DI
    Else
      Low DI             
    EndIf
   DelayUS 200     
   Input CLK               
   DelayUS 200
 Next X                   
 Input DI 
 DelayMS 29
Return

'--------------------------------------------------------------------------------

Resete:
Input Reset
Low Reset
DelayMS 5
Input Reset
DelayMS 300
Return

End
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I know, but worth the try. Last night I tried my new Sandisk. Same weird behavior. I took the wavs from Windows OS, small ones, and ad4 files only were 2kb long. Converted 16 tracks, some of them played great, other same defect. Only for a few seconds. It is not about the size, there is something wrong with the micro sd card brand, model or the audio module is defective. I requested a new one from eBay vendor.
  i had same beahaviour, i solved  first encoding the wave into 32khz then converting to AD4
Which program are you using to convert/tranform wav? Audacy? I tried all of them last week and got same results.
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

#wanderlg, your EnviarDatos() is wrong. Why don't you translate my library posted here:
http://arduino.cc/forum/index.php/topic,117009.0.html

Pretty sure I will work. And I can not test mp3 mode cause my module is only serial control mode.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

the strange thing is that he is playing the files using the buttons. touches not only using serial data. which may be? already tested it with 2GB sandisk microsd, but not yet tested it with microsd sandisk 1GB or less. help.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

# Argentina. enviadados on routine. I've tried many ways and nothing. not seem to be wrong, but already modified in every way. I've got your routine and remade in basic, but still not play.
« Last Edit: August 04, 2012, 10:50:44 am by wanderlg » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

# Argentina. if it is not asking too much, you have to send me a 2 files already converted me to see if this is my problem?
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Try to translate my latest version. Early version was not good. Had to reset it every time I played a voice. I am attaching a file for you. This one plays more than 10 secs for me.  And BTW, I did test a 2gb Kingston card and did not work. Our modules don't support more that 1gb. Are you sure you have the same module?

* 0013.ad4 (3130.32 KB - downloaded 37 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

#Argentina. this is my module: WTV020-SD-mini
as you click the one with bit 0 on pin 9, your module does not play?

now I have to leave, but so I'll try to get some more. I've slept and nights without anything. I stopped with 2 modules or 8 months.

thank you for your attention and help.

much peace.
Logged

Italy
Offline Offline
Full Member
***
Karma: 3
Posts: 151
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

#wanderlg, your EnviarDatos() is wrong. Why don't you translate my library posted here:
http://arduino.cc/forum/index.php/topic,117009.0.html

Pretty sure I will work. And I can not test mp3 mode cause my module is only serial control mode.

used goldwave first and then the somo as linked before
Logged

Pages: 1 ... 6 7 [8] 9 10 ... 12   Go Up
Jump to: