Pages: [1]   Go Down
Author Topic: Programming ATtiny w/ Arduino 1.0 as ISP  (Read 1668 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi guys, new here, and new to the Arduino as well.

I've hit a snag trying to use my Arduino Uno to program a ATtiny85 chip with a simple "blink" program. I'm following this tutorial.
http://hlt.media.mit.edu/?p=1695

I've loaded the Uno with the ISP sketch and hooked up everything correctly to the ATtiny85 as far as I can tell. As I understand it the 1.0 software requires the ATtiny85's fuse bits to be configured from 1MHz to 8MHz so the SoftwareSerial library with work with the chip. But when I hit "burn bootloader" (with "ATtny85 internal 8MHz clock" selected as board) I get an error message "avrdude: usbdev_open(): did not find any USB device "usb"".

Any ideas why it's not communicating with the chip?

I apologies if this is a common or trivial question, but a search came up dry.
Thanks.

-Tony
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 176
Posts: 12285
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Click Tools then Programmer then Arduino as ISP.  Try again to burn the bootloader.

An alternative to the HLT core...
http://code.google.com/p/arduino-tiny/
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ha, I knew it must have been something trivial I missed.
Thank you!
Logged

San Diego
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, awesome. I thank you as well!  Cheers.
Logged

saipan
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, i just started playing with arduino uno not long ago.. recently i got a few attiny85 and successfully load the basic "blinking" onto it (follow the steps on MIT web)... then i started to do some research of more attiny projects, i notice some say "bootloader" attiny85 to 8Mz. so i tried to do it. after i set it up (attiny85 8Mz,arduino as ISP), i click " burn bootloader", i got a message on arduino IDE that the bootloader burning failed.. now i can't load anything to attiny85 anymore.. i have tried switch back to 1Mz, only get message on arduino IDE

             "stk500_getsync(): not in sync: resp=0x00"

however, i can still load sketches to my arduino. only programme attiny doesn't work. can someone help?
thanks!

Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 176
Posts: 12285
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


The most likely culprit is wiring.  Ensure the wiring is correct.  Try different jumpers in case one (or more) is defective.
Logged

saipan
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i will give it another try. although i probably already rewired them 50 times..
will keep you posted, thank you mr badly.
Logged

saipan
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i got it!

after i rewired the board and restarted the IDE, uninstalled and reinstalled the programme many times.. i re-read the instruction in MIT high-low tech website and only realize i  forgot to upload the ISPsketch to my uno board first...

had i understand the concept before going thru the instruction steps, i would know to programme my uno before uno programmes the tiny..

thanks for help.

Logged

Pages: [1]   Go Up
Jump to: