Pages: [1]   Go Down
Author Topic: Arduino UNO + JY-MCU v1.03 problem  (Read 2966 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello.
I have connected my arduino UNO with JY-MCU bluetooth version 1.03.
I have connected it's rx,tx to pins 2,3 of the arduino.
After running the program I am sending AT command and it returns OK. But I don't know any other commands, I have checked several of them, like AT+VERSION or AT+VERSION? nothing is returing.
1. Is there a special list of commands for my version of JY-MCU?
2. Another question is how to send data through BT? What kind of command should I be used in order to send, for example, one byte of data to Arduino? (I am planning to connect this Bluetooth to Ardiono pins 0,1 and send data from Android device by bluetooth.)


 
Logged

Switzerland
Offline Offline
Faraday Member
**
Karma: 108
Posts: 5144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You can find a documentation of the AT command most of this modules understand here:

http://www.linotux.ch/arduino/HC-0305_serial_module_AT_commamd_set_201104_revised.pdf

There are different version of the JY-MCU around, some with a HC-03, HC-05 or HC-06 submodule. But most of the commands in the document work in all versions.
Logged

Delray Beach, FL USA
Offline Offline
Full Member
***
Karma: 0
Posts: 113
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Actually, the HC06 has very few AT commands, and works considerably differently (like, it doesn't want or provide a newline - it operates on timing, so typing by hand is virtually impossible). Baud rate setting is the only important thing you can change.

http://byron76.blogspot.com/2011/09/one-board-several-firmwares.html

has some good info on the differences between versions and the AT commands supported.
Logged


Pages: [1]   Go Up
Jump to: