Go Down

Topic: Issue installing leonardo drivers (Read 38737 times) previous topic - next topic


Confirming what Clamon and others have said, there does seem to be an issue with Leonardo drivers on a few specific models of Dell and, apparently, HP laptops.  I'm working with one community member now to track down the bug and hope to have a fix soon.

Hey and what is the possible origin of the problem?

I suspect something having to do with the "flip" between processor and communications ports.  The IDE works well enough for me to upload sketches but serial communications via USB (e.g. Serial Monitor) fail on my older XPpro machine.  I do the same on my Vista machine with no problems.  One is an older Compaq, the other is a recent HP.  The older Compaq works perfectly with all other Arduinos.  Both PC's are using the same drivers for the Leonardo device.


Sep 09, 2012, 01:21 am Last Edit: Sep 09, 2012, 01:23 am by Ya-Nvr-No Reason: 1
I am having the same issue using a lenovo and win7
tried several times several different ways.
Shows it is uploading it to com4 and completes but nothing is updating/changing on the board itself.
Tried  forcing a driver install of leonardo on com9 but it never updates when I plug in the usb cable, just the com4 port.

Have no issue with the Mega 2560 Rev3 board


I had the same problems. What i did?

Download these drivers: http://www.ftdichip.com/Drivers/CDM/CDM%202.04.16%20WHQL%20Certified.zip

And follow this:

Open the Device Manager (type 'Device Manager' in the Start Menu' search box)
Look for the Leonardo in either "Other Devices" or "Ports"
Right-click in the Leonardo and select "Update Driver Software…"
In the dialog box, select "Browse my computer for driver software"
In the next box, select "Let me pick from a list of device drivers on my computer", and click 'Next'
In the next dialog, click "Have Disk" (you don't have to wait for the computer to retrieve the entire list)
This will open an "Install From Disk" dialog. Browse to your arduino installation folder (on my computer, it's C:\Program Files\arduino-1.0.1\drivers\Arduino Leonardo)Click OK.
Click Next (ignore any warnings about the driver being not digitally signed)
If a Windows Security dialog appears, select "Install this driver software anyway"
The dialog should say that Windows has successfully updated you driver software
Close the dialog and restart your computer.
After the restart, open the Device Manager again.

I hope that works for you guys!

Louis Davis

The Leonardo does not us an FTDI chip, therefore downloading the FTDI drivers is not necessary.


OK, we now have the Leonardo working on this Lenovo Win7 32bit computer - in fact we have two - Element-14 is selling Leonardo board without headers for $24. The 1.5m cable is not a problem. Also, the Leonardo is fulling working and the reset button does not need to be pressed. When downloading the Leonardo seems to switch to breathe mode automatically. When the ASCII table sketch runs, it is now superfast and takes about 0.5s to print all the ASCII characters with hex codes etc, while the Uno runs at 9600 and takes 30 seconds or so to do the 100 ASCII characters.

We haven't done anything, but last night Microsoft did a Windows 7 update - in fact 5 updates - so this was probably a Steve Ballmer problem.

Will test this out on the HP laptop upstairs soon.

Also, with the faulty Mega2560, this is at a friend's place and he was using a Dell laptop.


can you say what 5 updates you installed?


Sep 14, 2012, 07:20 am Last Edit: Sep 14, 2012, 07:27 am by Shields_Arduino Reason: 1
Here are the updates installed in the last two days

Update for Windows 7 KB2719857 13/9
Update for Windows 7 KB2735855 13/9
Update for Windows 7 KB2741355 13/9
Update Rollup for ActiveX KillBits for Windows 7 KB2736233
& 2 Microsoft Security Essential updates and a Window Malicious Software Removal tool

Also, just before the Leonardo started working, Device Manager showed two icons for the Arduino Leonardo and then installed the drivers for each.

Just checking on the laptop now. --> Both Leonardo boards both work on the HP laptop fine now.


Looks like your running a 64 bit OS based on those updates.


Sep 14, 2012, 11:39 am Last Edit: Sep 17, 2012, 09:01 am by Shields_Arduino Reason: 1
Pretty sure the PC is 32 bit - will check later - it is 3 yrs old.

Also, just realised that the HP laptop was working fine - the sketch had a problem. For some reason, the Leonardo board cannot run the Tone() function - the sketch actually crashes so make sure Tone() is commented out if using the Leonardo.

Also, it can be very difficult to download a new sketch to a Leonardo. Pressing and holding the reset button until Uploading does help although it can still take ten goes to redownload to the Leonardo - watch the LEDs and when TX/Rx lights illuminate together for a second the sketch has probably downloaded. Note the Leonardo is superfast at downloading. I downloaded a Leonardo keyboard example sketch and it was very hard to re-download and the Leonardo was trying to overwrite the sketch with repeated characters which was worrying ( but what the sketch was programmed to do).

Here is a fix for the Tone issue:


Sep 16, 2012, 04:21 pm Last Edit: Sep 22, 2012, 03:40 pm by Ya-Nvr-No Reason: 1
2560 works the Leonardo refuses to work
I can even access the 2560 R3 and a UNO R3 thru a B&B USB over Ethernet Device UE204
Also updated Win 7 32 bit with the latest downloads.

Louis Davis

The CP2102 is USB to UART chip from Silicon Labs.

You can get the drivers for this device here: http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

None of the official Arduino boards have ever used this chip, so you must have a clone.


Sep 21, 2012, 06:23 pm Last Edit: Sep 22, 2012, 03:37 pm by Ya-Nvr-No Reason: 1
It turns out it was the cable!!!
Purchased a new cable from sparkfun and now it recognized the board and works fine.
So Ya-Nvr-No
Never Give up


I had an Arduino Leonardo for Xmas. The laptop (Dell XPS 1330) does not seem to recognize the driver, no matter the vesion I install. Anything new about first Clamon's post??
Thank you


It has more to do with what operating system you have rather than the laptop model.  What system do you have installed?
Accelerate to 88 miles per hour.


Feb 12, 2013, 11:45 am Last Edit: Feb 13, 2013, 01:42 am by radomp Reason: 1
I had the same problem. To fix this, I disable Windows' driver signature checking. To do this, reboot as normal and press F8 like crazy. Then you will have the advanced boot menu and select "Disable Driver Signature Enforcement". This should solve the problem but only if I use usb2 port. For some reason, I cannot use usb3. 

Go Up